sync ajax query never fire onreadystatechange

RESOLVED DUPLICATE of bug 313646

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 313646
10 years ago
10 years ago

People

(Reporter: Lampa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

4.58 KB, application/octet-stream
Details
785 bytes, application/x-php
Details
(Reporter)

Description

10 years ago
User-Agent:       Opera/9.51 (X11; Linux x86_64; U; en)
Build Identifier: 3.0, 2.0.0.14

When using sync (script waits for ajax response) never fired onreadystatechange. Result is useless. Created html + php file to reproduce. Async works perfectly, sync not.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
nothing


I know that bug was already reported. But still no repaired. Opera, IE works ok, only FF has problem (from old versions)
(Reporter)

Comment 1

10 years ago
Created attachment 326868 [details]
html contains form + ajax
(Reporter)

Comment 2

10 years ago
Created attachment 326869 [details]
response for ajax query

contains one php command (to simulate longer running scripts) + text reply
(Reporter)

Comment 3

10 years ago
Found that if use firebug extension (for 2.0.0.14) works perfectly.

Comment 4

10 years ago
I am seeing this same problem.  For me, the issue is limited to FF 3.x versions.  All versions 2.x.x.x are working.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 313646
You need to log in before you can comment on or make changes to this bug.