If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Minimonth] Some all-day and all multiple-day events are not shown in bold

VERIFIED DUPLICATE of bug 399761

Status

Calendar
Calendar Views
VERIFIED DUPLICATE of bug 399761
9 years ago
9 years ago

People

(Reporter: Fabi, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Lightning 2008062520

All-day events will not always be marked bold in the minimonth view. Some will, some won't. New all-day events are never shown in bold in the minimonth view. 

All multiple-day events will not be shown bold in the minimonth view.

This happens for local calendars and gcal.

Reproducible: Always

Steps to Reproduce:
1. Create a new event spanning multiple days.
2. Look at the minimonth view
Actual Results:  
Days where the event was added are NOT shown in bold in the minimonth.

Expected Results:  
Days should be shown in bold.
(Reporter)

Comment 1

9 years ago
Created attachment 326907 [details]
screenshot

Screenshot:

The events on the 22nd, 27th and 30th are all from the same calendar, but only two of them are bold in the minimonth.

Comment 2

9 years ago
Might be related to Bug 399761 and/or Bug 435493. Do you have events/tasks on that day that are not shown in view but in the minimonth?
(Reporter)

Comment 3

9 years ago
(In reply to comment #2)
> Might be related to Bug 399761 and/or Bug 435493. Do you have events/tasks on
> that day that are not shown in view but in the minimonth?

Seems like this is related to Bug 399761. The problem is, that some events are marked "busy" and some "free" so some show up in the minimonth, some don't. I added events via Lightning, my SonyEricsson phone and gcal so there must be different default settings somewhere...

I personally think, that all-day and multiple-day events should be "busy" by default, or at least there should be the option to make it default.

But I guess the discussion about that is in Bug 399761. 

Duplicate?

Comment 4

9 years ago
Are some of the events marked as Private and some as Public? Are some of the events marked as Busy and some as Free? You can check this from the Edit Event dialog Options -> Privacy resp. Options -> Show Time As.
(Reporter)

Comment 5

9 years ago
(In reply to comment #4)
> Are some of the events marked as Private and some as Public? Are some of the
> events marked as Busy and some as Free? 

When creating a new all-day event with a local calendar the event is marked as "free" and NO privacy setting is selected. --> not shown in minimonth

When creating a new all-day event with a google calendar the event is marked as "free" and the privacy setting "Google defualt" is selected. My google cal is private --> not shown in minimonth

As soon as I change any of these events to "public" the time is automatically set to "busy" --> shown in minimonth

When I change any of these events to "busy" (even private calendars) --> shown in minimonth

So, when any event is marked "busy" it is shown in the minimonth. 
What's not really clear form an user's point of view is, whether an event is "busy" or "free" by default.

- create any all-day event --> not shown in minimonth
- create any timed event --> shown in minimonth


Comment 6

9 years ago
(In reply to comment #5)

The default free/busy states can be controlled via advanced preference "calendar.allday.defaultTransparency". Set it to "TRANSPARENT" (free) or "OPAQUE" (busy).

The current mini-month displays marks only days as bold that contain events marked as busy -> current behavior is as intended. Behavior is already under discussion in Bug 399761, resolving as duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 399761
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.