The default bug view has changed. See this FAQ.

Setting % Complete in Edit Task dialog to <100% on previously completed task does not reset completed status

RESOLVED FIXED in 2.1

Status

Calendar
Tasks
--
minor
RESOLVED FIXED
9 years ago
4 years ago

People

(Reporter: Lifesaver2000, Assigned: Decathlon)

Tracking

unspecified

Details

Attachments

(1 attachment, 1 obsolete attachment)

3.95 KB, patch
Decathlon
: review+
Details | Diff | Splinter Review
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Thunderbird version 2.0.0.14, Lightning 2008062520

In the task mode, if I have a task that is marked completed with the check box, then right click and select a percentage of completion less than 100%, the check mark and the line through the text goes away (as it should) and the task is no longer treated as completed. But if I double click the item then set the percentage to less than 100% in the Edit Task dialog window, the item remains checked and struck through, and still shows as completed in the context menu.

Reproducible: Always

Steps to Reproduce:
1. Open Edit Task Dialog for a task previously marked as completed by the checkbox
2. Set the "% complete" to less than 100%
3. Save and Close
Actual Results:  
The Completed checkbox remains checked, the item is struck through, and it still "behaves" like a completed task.  The progress bar does show the correct percentage of completion, even though the completed checkbox is checked.

Expected Results:  
The item should no longer be marked as completed if progress is less than 100%

Everything works as expected if the progress percentage is selected from the context menu in either task mode or in the Today Pane.
(Reporter)

Comment 1

9 years ago
Some additional.  This bug may be invalid, and may actually need to be worked on from a different angle.

I realized that in the Edit Task dialog, the status drop down does not automatically change from "Completed on" to "In process" when the percent complete is changed to less than 100%.  Changing this to "In process" when changing the % complete makes everything behave as expected.  But, this still isn't right, in my opinion.

I suggest that EITHER the Status should change to "In process" automatically if the "% complete" is changed to less than 100%, OR it should not be possible to edit the "% complete" unless the status is changed to something other than "Completed on."  This will avoid the conflict in the task view that is possible between the progress bar and the completion check box.

Unless, of course, a task can be completed yet not 100% Complete.  For me, that doesn't work, but maybe I am missing something.
Confirming on today's Sunbird nightly build
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 3

5 years ago
I noticed a similar problem. I often need to mark a task as completed and create another identical task at a different date in the future, this latter one without the "completed" status. So I copy the first (completed) task and paste it as a second identical task. But this second task remains struck out, no matter if I try to set the status as "not specified".
(Assignee)

Comment 4

5 years ago
Created attachment 676957 [details] [diff] [review]
patch - v1

I've tried to address the request in comment #1. 

This patch changes the status to COMPLETED when the user types or selects 100 in the percent-completed-textbox, and changes the status to IN-PROCESS when the percent complete becomes less than 100. It also changes the percent completed to 99 when the user changes the status from COMPLETED to IN PROCESS or to NEEDS ACTION. I'm not sure if the percent complete text box has to be enabled with the NEEDS ACTION status selected (I've found nothing on RFC5545) so I've left it as it is.
Moreover it sets the percent complete textbox to 0 when the "Not Specified" status is being selected.
Assignee: nobody → bv1578
Status: NEW → ASSIGNED
Attachment #676957 - Flags: review?(matthew.mecca)
Comment on attachment 676957 [details] [diff] [review]
patch - v1

Review of attachment 676957 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good overall, r=mmecca with the following:

::: calendar/base/content/dialogs/calendar-event-dialog.js
@@ +2401,5 @@
>    }
>  
> +  if ((status == "IN-PROCESS" || status == "NEEDS-ACTION") &&
> +       oldPercentComplete == "100") {
> +      setElementValue("percent-complete-textbox", "99");

Since tasks can be in the state of in-process or needs-action without having any portion of the task completed, I think it would be safer to set the percent completed back to 0 here, otherwise we're making an assumption that some portion of the task is still completed which may not be true.
Attachment #676957 - Flags: review?(matthew.mecca) → review+
(Assignee)

Comment 6

4 years ago
Created attachment 678494 [details] [diff] [review]
patch - v2

Corrected the patch as requested in the previous comment.

r=mmecca
Attachment #676957 - Attachment is obsolete: true
Attachment #678494 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Pushed to comm-central changeset 6bb72428dcfd
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.