Inconsistent key shortcuts for opening items in tabs causes destructive behavior

VERIFIED DUPLICATE of bug 301888

Status

()

VERIFIED DUPLICATE of bug 301888
10 years ago
10 years ago

People

(Reporter: siegeljd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

n FF2 for Windows, if a user right-clicks a link on a web page and wants to choose Open in New Tab, the shortcut key is "T".

But if a user right-clinks a saved bookmark in the sidebar and wants to open that in a new tab, the shortcut key is "W".

Worse, hitting "T" with that context menu open deletes the selected bookmark, with no undo, even though "T" is not the listed shortcut key in the context menu ("D" is).

Summary:
Ctrl-T opens a new Tab.
Context-menu-T on a link in a web page opens the link in a new tab.
Context-menu-T on a saved bookmark in the Sidebar deletes the bookmark, with no undo.

In this case, in 2 out of 3 instances, "T" has the expected and nondestructive behavior of doing something in a new tab. In the 3rd instance, it has a destructive effect.

I haven't upgraded to FF 3 but I understand the behavior is the same.

Reproducible: Always

Steps to Reproduce:
1.  Right-click a bookmark in the Sidebar
2.  With the context menu open, strike the "T" key
3.
Actual Results:  
Bookmark is deleted

Expected Results:  
Either (1) bookmarked page appears in new tab, or (2) at minimum, nothing happens.

Considered listing as Major only because of the destructive behavior exhibited.  In the end left as Normal but there is a case for Major severity because of unexpected and destructive behavior.

Of course there is a workaround ("Doc!  My bookmark disappears when I hit 'T' with the context menu open!"  "OK, so don't hit 'T' with the context menu open!")  but keyboard users develop muscle memory and habits to speed their work -- that's the entire point.  So anomalous behavior of a particular key is a major impediment to using the keyboard to speed work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 301888

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.