Windows media player plugin uses different cookies (session_id) when loading content

RESOLVED DUPLICATE of bug 408516

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 408516
10 years ago
10 years ago

People

(Reporter: Johan Adriaans, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Short description:
The Windows Media Player plugin in firefox 3 uses its own cookies (probably Internet Explorer cookies), and not the ones used/stored by Firefox 3

Long description:
I am trying to secure a webstream with PHP using session data. I use a PHP generated .wvx file to shield the actual stream url. The .wvx file is generated using session data. In Firefox3 this does not work. FF2 and IE are fine, but after sniffing my network data i found out the Media player plugin (9.00.00.3354) in firefox3 uses a different session cookie.

Reproducible: Always

Steps to Reproduce:
1. Use server side language to generate a .wvx file based on the session data
2. Embed windows media player code in html page with generated .wvx as source file
3. Example + source: http://www.izi-services.nl/streamtest/
Actual Results:  
There was no video

Expected Results:  
There should be video

- Firefox 3 problem
- Using a dutch operating system
- My Media player plugin version:: 9.00.00.3354, but reproduced using other versions
- Used to work in Firefox 2

Example + source: http://www.izi-services.nl/streamtest/
Firefox doesn't read IE cookies at all, it would be the WMP plugin that does this.
Component: OS Integration → Plug-ins
Product: Firefox → Core
QA Contact: os.integration → plugins
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408516
(Reporter)

Comment 3

10 years ago
Sorry about the duplicate bug, i did search for an existing bug before posting.. I'll look better next time. Also it doesn't seem to work in FF2 either! So its an all version bug..
That the plugin is using IE cookies is a bug in the plugin, not in Firefox because Firefox doesn't read IE files (except during the import phase when you use Firefox the first time).
If you can read cookies through NPAPI then there is nothing we can do and if NPAPI doesn't support reading cookies (which the 2 bugs posted in 408516  suggests) then this is a "missing feature" and not a bug :-)

NPAPI= Netscape Plugin Application Programming Interface
All browsers are using NPAPI Plugins except IE above IE5. IE6+ is using ActiveX plugins
You need to log in before you can comment on or make changes to this bug.