Closed Bug 442220 Opened 12 years ago Closed 12 years ago

WCAP event: Timezone 'UTC/GMT' changed automatically to 'Europe/London'

Categories

(Calendar :: Provider: WCAP, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: dbo)

Details

Attachments

(1 file)

STEPS TO REPRODUCE:
===================

- create an new event in your WCAP calendar
- change timezone to 'UTC/GMT'
- save this event
- reopen the edit dialog and check the timezone

RESULT:
=======

- the timezone is 'Europe/London'

EXPECTED RESULT:
================

- the timezone should be 'UTC/GMT'

REPRODUCIBLE:
=============

- always
Flags: blocking-calendar0.9?
By now this seems to be a server bug/limitation, because cs adds a X-NSCP-DTSTART-TZID even though I haven't passed one when storing the event (similar to bug 442220). I am asking Praveen for help. Nevertheless, this won't block the release, but I'll fix it if there's a way.
Flags: blocking-calendar0.9? → blocking-calendar0.9-
CS doesn't support UTC/GMT. Using an equivalent timezone like "Africa/Casablanca" is no solution, thus this patch removes UTC/GMT from the timezones dialog for WCAP.
Attachment #330827 - Flags: review?(philipp)
Status: NEW → ASSIGNED
Attachment #330827 - Flags: review?(philipp) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH => FIXED.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
checked in lightning build 2008072318 and sunbird 20080723 -> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.