If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

X11 Crashes When Loading This Webpage (Large Page)

VERIFIED INVALID

Status

()

Firefox
General
--
critical
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Josh W, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0

Almost every time I visit this page in Firefox 3.0, X11 unexpectedly crashes while the page is loading. I have asked several colleagues to reproduce this, and their machines are able to reproduce the crash. This did not occur in Firefox 2, and I have been able to access the page in a different browser.

This is a critical bug, because it has the potential to cause data loss when X11 crashes.

Reproducible: Sometimes

Steps to Reproduce:
1. Visit http://esrl.noaa.gov/gmd/aero/data/datafmt.html in Firefox 3
2.
3.
Actual Results:  
X11 Crashes, and the session restarts.

Expected Results:  
The page should have loaded properly, and not have caused X11 to crash.

X11 Log File Output (only the error):

Fatal server error:
Unknown GTT size value: ffffffff
Please report this to the X developers.
It doesn't matter if you get this only with Firefox, X shouldn't crash.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Comment 2

9 years ago
http://viper.haque.net/~timeless/blog/143/

file a bug against your xserver vendor. feel free to report the bug id here.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.