Startup Preference Support

RESOLVED DUPLICATE of bug 519574

Status

RESOLVED DUPLICATE of bug 519574
11 years ago
9 years ago

People

(Reporter: dougt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
I am implementing a new feature that is going to be disabled by default via a preference.  As part of the landing criteria, i am required to also provide unit testing.  I am using mochitest to provide said testing.

The way I implemened this enable-feature preference is that the preference is read once at startup, and is not read in again.  So, toggling the preference at run time does nothing.

It might be a nice feature to be able to set preference before the application that is going to be test is started.
jgriffin added a --setpref=pref=value in bug 519574.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 519574
You need to log in before you can comment on or make changes to this bug.