Closed Bug 442304 Opened 14 years ago Closed 13 years ago

pop up menus on page are not displayed properly

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: paul, Assigned: roc)

References

()

Details

(Keywords: regression, testcase)

Attachments

(7 files, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

The pop up menus on left of http://centralflorida.cox.net/cci/home under the CHANNELS topic list cannot be seen because they are displayed under the adjacent content area rather than on top of it.

Reproducible: Always

Steps to Reproduce:
1.go to http://centralflorida.cox.net/cci/home
2.mouse over menu items under CHANNELS list of topics on left of page
3.
Actual Results:  
pop up menus cannot be read because they appear under adjacent content area (to the right) instead of on top of it

Expected Results:  
expected pop up menus to appear on top of adjacent content area

no other info
This regressed on 25 Jan 2006, probably from Bug 317375.
Blocks: 317375
Component: General → Layout
Keywords: regression
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
Need a simplified testcase
Attached file testcase
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Assignee: nobody → roc
Flags: wanted1.9.1?
Flags: wanted1.9.1? → wanted1.9.1+
Attached patch partial fix (obsolete) — Splinter Review
The problem here is that "quirky clipping" for table cells in oversized percentage-height situations is kicking in.

This patch limits the damage by only clipping to the cell bottom edge, not to the sides or above the cell, which I think is what I originally intended to write.

But we're still clipping the green box at the bottom. This is because the cell height is set to be greater than the DIV height (I don't know why, that's table height voodoo), then the DIV is centered vertically within the cell. Webkit makes the cell the same height as the DIV, and Opera makes the cell bigger than the DIV but doesn't clip (I think).

FF2 has yet another behavior, which is that adding position:relative to the DIV makes it completely escape the clipping performed by the cell.

I have no idea what the desired behaviour is. I don't really know anything about this quirk. Implementing the FF2 behaviour is pretty easy though. Maybe we should just do that for now.
Looking at the Gecko 1.8 code I can't see why the rel-pos child escapes the clipping, though.
Attached patch fix (obsolete) — Splinter Review
OK, so the previous patch was the wrong file.

This patch actually is enough to fix the site in question. So I think we should just take this. It's a conservative fix --- we're just "quirky clipping" less.
Attachment #339938 - Attachment is obsolete: true
Attachment #339941 - Flags: superreview?(dbaron)
Attachment #339941 - Flags: review?(bernd_mozilla)
1. this looks like a hack and not like a fix (sorry Robert this is not personal)
2. the whole quirks mode clipping is hack
3. what we currently do is some sort of clipping which just doesn't work even for easiest cases
4. Webkit and Opera do not do the clipping, FF2 also does not the do the clipping! IE does.
5. We don't have a single bug report asking for clipping in quirks mode (at least I do not know one)

==> Whats the point of keeping this nonworking quirk?
Attachment #340772 - Attachment description: testcase "demonstrating" that our quirksmode clipping → testcase "demonstrating" our quirksmode clipping
Attachment #339941 - Flags: review?(bernd_mozilla) → review-
Comment on attachment 339941 [details] [diff] [review]
fix

I know, see point 3), but I assumed that it works. And the experiment shows it does not. Or at least in the typical use case it does not work. And then I put the question, why we keep some sort of half implemented(non working) thing that nobody asks for over 2 years and worse add one more layer of code that is far from obvious why it works differently in x and y.

So 1. the patch does not even fix the testcase the bottom black line of the lime box is not shown.
2.) if the rel. positioning is done vertical, the box does not show.
3.) IE, webkit and Opera show the lime rectangle in the slightly modified testcase.
Here's a testcase where it "works" in FF2, at least, it does something.

Maybe you're right and we can get rid of this quirk. I'd be very happy about that. But I'd like to understand why it was originally put in, and if that reason ever made sense, then I'd like to understand why it's no longer needed. That would give us a strong clue as to what, if anything, might break if we remove this quirk. Right now we don't seem to know the answers to any of those questions.
Apparently in bug 245434 you made this quirks-mode-only.

The behaviour was originally added for bug 111872, but I don't see why. That bug looks like it was an incremental reflow bug.

So yeah, let's just remove that quirk completely.
Attached patch fixSplinter Review
Okay, let's remove the quirks code completely.
Attachment #339941 - Attachment is obsolete: true
Attachment #340897 - Flags: superreview?(dbaron)
Attachment #340897 - Flags: review?(bernd_mozilla)
Attachment #339941 - Flags: superreview?(dbaron)
Comment on attachment 340897 [details] [diff] [review]
fix

sr=dbaron.  Removing quirks that aren't needed is good.
Attachment #340897 - Flags: superreview?(dbaron) → superreview+
Comment on attachment 340897 [details] [diff] [review]
fix

Why don't you just r+ this, then we can get it in for beta. I'm pretty sure this is what Bernd wanted anyway
Attachment #340897 - Flags: review?(bernd_mozilla) → review?(dbaron)
Attachment #340897 - Flags: review?(dbaron) → review+
Attached file use case of the quirk
only when reading the patch I recognized when we "use" this quirk, so basically we are switching  to Operas rendering of this. Webkit does in principle the same I do not know why they bork on this.
So the question here boils down do we want to display overconstrained pct tables outside the cell and make the designer error obvious. It just escaped my mind that the width case doesn't work since a long time.
Its a difficult decision, it includes the f-word of tables (pct height), that I do not want take alone, David will your r+ still stand? It might be worth to try to remove it anyway. So from my perspective r+, but we might need to revisit it if a lot pages use this (which I assume they do not).
OK, I'll land this post-beta-1 and we'll see how things go.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.