Text input with transparent background calculates highlight scheme from inheritance, not visual layout.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: gansos, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_3; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.1 Safari/525.20
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Visible in FireFox windows and Linux variants.

When a text input field has a transparent background, Firefox calculates the selected text color and background highlight from the DOM inheritance. It should calculate these colors from the visual rendering of the page.

For example, a page has a black background, and a text input has a background color of transparent. Then, the input is given an image background that is white. When a user tries to highlight text within the field, the text changes color, but the highlight box is white (to offset the black) and so is not visible. This looks very odd.

In the above situation, Firefox Mac properly renders a light blue text highlight, but Firefox Win renders it white (FireFox Linux also renders it white). The visual effect looks like the text is not actually selected.

Reproducible: Always

Steps to Reproduce:
1. Create a text input field with the CSS background property set to "transparent" in a containing element with a dark background color (#000).
2. Give the text input a white background image.
3. Enter some text in the field.
4. Click and drag inside the field to select the text.
5. Observe lack of appropriate highlighting.
Actual Results:  
Text is highlighted with white, which is not visible due to white text field.

Expected Results:  
The text should exhibit a contrasting color for the highlight. It should know that the actual value of the text field background is white (from the image) even though the inherited background color is black (from the body).
This is a mass search for bugs that are in the Firefox General component, are
UNCO, and have not been changed for 800 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile,
http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you
still see the bug, please update this bug. If the issue is gone, please set the
resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.