Content copied with Edit->Copy can't be pasted into other apps

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
normal
RESOLVED WORKSFORME
18 years ago
7 years ago

People

(Reporter: Christos Cheretakis, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using the keyboard, nothing happens. WHen using the context menu and selecting
copy, both copy & cut are disabled and nothing is copied to the clipboard.
Checked on linux/062808

Comment 1

18 years ago
able to reproduce this bug with build 2000062808 on both Win98 and Linux
not possible to copy/past e.g. this form i'm adding the comments in now.

Comment 2

18 years ago
Confirmed on 2000062914 on Linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
This is what happens when I tried to copy and then paste content from and to the
"additional comments" text area:

->>>>>>>>>>>>>> Write Clipboard to memory
->>>>>>>>>>>>>> Read Clipboard from memory
Transferable didn't support data flavor text/unicode (type = 219)
->>>>>>>>>>>>>> Read Clipboard from memory
Transferable didn't support data flavor text/unicode (type = 485)
->>>>>>>>>>>>>> Read Clipboard from memory
Transferable didn't support data flavor text/unicode (type = 31)
->>>>>>>>>>>>>> Read Clipboard from memory
Transferable didn't support data flavor text/unicode (type = 484)

Comment 4

18 years ago
This is a duplicate of bug 42625 (that's listed as a mac bug though, so maybe
not)  Please reopen if this is not fixed by the recent fix for 42625.

*** This bug has been marked as a duplicate of 42625 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
It seems to be fixed on 2000063008.
(Reporter)

Comment 6

18 years ago
Checked with 062920:
- copy&paste works between form elements & location bar
- copied text is NOT copied to system clipboard, which means
- pasting into ns4.73's location bar gives the last text i copied to clipboard
- pasting after that in mozilla's form fields produces this text:

// Menu for testing.My Sidebar is currently empty.You may add panels by clicking
on the "Add" button above, and then clicking on "Customize..."If you would like
to completely hide My Sidebar, click on the "View" menu above and select "Sidebar."

downloading latest nighly right now. Will report more in a while.
(Reporter)

Comment 7

18 years ago
copy&paste works only inside mozilla without problems, system clipboard is not
affected however
063008, linux

{It's now July on this place of the earth!!! :-)}

Comment 8

18 years ago
agreed.  I see thi with 063008 win32 build as well.  c&p within mozilla fine,
but not to other apps.

saari, akkana said you might have some insight on this one if it's a focus problem.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 9

18 years ago
win32 2000070408 worksforme on wi98

Comment 10

18 years ago
adding pavlov to this bug.  Pavlov, can you shed any light on this?

Comment 11

18 years ago
"copy" works just fine for me: if I select some text in a form widget and select
"edit->copy" I can paste in other applications with a middle-click (native X
paste command).

However, if I select text in a terminal window, I can paste it into a form
widget by middle-clicking but NOT through "edit->paste."

Note, however, that in Linux/X11, the "edit->copy" command is redundant and
unneeded: merely selecting text automatically copies it to the system
"clipboard." If the edit->copy command is somehow borked, we'd never notice.

Comment 12

18 years ago
However ... Using shift + navigation keys to select text, then using Edit ->
Copy, one can't paste that text into another application.

Edit -> Select All (ctrl-a) on a web page, Edit -> Copy (ctrl-c), try to paste
into another application. Doesn't work either. Do we copy onto the system
clipboard at all?

Changing the summary.
Summary: Cannot copy&paste from form elements → Content copied with Edit->Copy can't be pasted into other apps

Comment 13

18 years ago
over to Toolkit.  Is clipboard stuff handled by Toolkit or Apps?
Assignee: asa → trudelle
Status: REOPENED → NEW
Component: Browser-General → XP Toolkit/Widgets
QA Contact: doronr → jrgm
(Assignee)

Comment 14

18 years ago
All of this worksforme using the latest N6 branch verification build on RH 6.2.
 If you're seeing some specific failure, please open that in a new bug with
exact steps to reproduce. Don't morph this bug any further. resolving as wfm
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.