Create library for expiring content on the netscaler

RESOLVED FIXED

Status

mozilla.org
Webdev
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: clouserw, Assigned: clouserw)

Tracking

Details

(Assignee)

Description

10 years ago
We need a library we can include in our projects that can talk to the netscalers (via the API they provide) and expire content.
How does this relate to bug 376759?

Is bug 376759 going to use the library created by this bug or is it pretty much a dupe?

Comment 2

10 years ago
At the moment, it's a dupe -- but I'd suggest we morph the old bug so it depends on this and does what you say in comment 1.
(Assignee)

Updated

10 years ago
Depends on: 444704, 444782
(Assignee)

Updated

10 years ago
Depends on: 444844
(Assignee)

Comment 3

10 years ago
(In reply to comment #2)
> At the moment, it's a dupe -- but I'd suggest we morph the old bug so it
> depends on this and does what you say in comment 1.
> 

Works for me.  Moving along with that, I've just landed v0.1 of the library at http://svn.mozilla.org/libs/ns-api/ .  It gets and expires content right now.  Please read the README.  I finished all but 2 unit tests which have comments in them and instructions for finishing them.

As a side note, the API is really extensive - something like 2500 methods are available, everything from statistics to complete control of all rules, permissions, caching details, etc.  If we want to expand the library it is pretty easy to do.
(Assignee)

Comment 4

10 years ago
library and tests are checked in
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Duplicate of this bug: 376759
You need to log in before you can comment on or make changes to this bug.