Closed Bug 442392 Opened 12 years ago Closed 12 years ago

Expected errors are notified via dialog box

Categories

(Calendar :: Internal Components, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: Fallen, Assigned: dbo)

References

Details

Attachments

(2 files)

Due to the recent changes in error notifications, some now expected errors are shown in a dialog.

For example, if you click on an invitation email in lightning, getItem fails for all calendars that don't have the item. This is ok, but an error dialog shows up.

berend, could you look into this?
Flags: blocking-calendar0.9?
I think we just shouldn't fire onError in that case, because probing for an item (by id as well as by range) is a valid use case.
Flags: blocking-calendar0.9? → blocking-calendar0.9+
Attached patch fix β€” β€” Splinter Review
Attachment #328382 - Attachment is patch: true
Attachment #328382 - Attachment mime type: application/octet-stream → text/plain
Attachment #328382 - Flags: review?(philipp)
Assignee: nobody → daniel.boelzle
Status: NEW → ASSIGNED
BTW: gdata untested
Duplicate of this bug: 443167
Comment on attachment 328382 [details] [diff] [review]
fix

r=philipp for memory,storage,wcap
Attachment #328382 - Flags: review?(philipp) → review+
Attached patch alternative gdata fix β€” β€” Splinter Review
This looks a bit better for gdata, please check it in instead
Attachment #328454 - Flags: review?
Attachment #328454 - Flags: review? → review+
(In reply to comment #6)
> This looks a bit better for gdata, please check it in instead
Done that, though I think throwing an exception with result code NS_OK is a bit odd.


Checked in on HEAD and MOZILLA_1_8_BRANCH => FIXED.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
Checked in nightly build 2008073004 -> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.