Preference: "When Camino Starts: Load the pages that were open before quitting" not working.

VERIFIED INVALID

Status

Camino Graveyard
Preferences
VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: Andrew Mackenroth, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.14) Gecko/20080512 Camino/1.6.1 (like Firefox/2.0.0.14)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.14) Gecko/20080512 Camino/1.6.1 (like Firefox/2.0.0.14)

After selecting the preference to load the pages that were open before quitting when Camino starts, Camino still always starts on the home page, even after quitting on another page/pages.

Reproducible: Always

Steps to Reproduce:
1. Check the General Preference "When Camino Starts: Load the pages that were open before quitting"
2. Go to any web page or web pages aside from the home page.
3. Close window.
4. Quit Camino.
5. Start Camino.
Actual Results:  
Camino started on the home page instead of on the pages that were last open before I quit.

Expected Results:  
Started on the pages that were last open before quitting.
(In reply to comment #0)
> 3. Close window.
> 4. Quit Camino.

This indicates you had no pages open before quitting.

Comment 2

10 years ago
Yep, if you closed all your windows before quitting then that's the expected behavior, because they weren't open any more. If you want them to re-open, they need to still be open when you quit.

Perhaps we should change it to "when quitting" rather than "before quitting", but I'm not sure it really adds much clarity, and it's a bit more awkward.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

10 years ago
Okay. I guess I just expected that particular feature to behave the way it does in Firefox.

Comment 4

10 years ago
I would guess that the way it behaves in Firefox is an artifact of the fact that on other platforms, closing the last window quits the program; their behavior makes no sense on the Mac, since if 5 windows are open, you close all of them at once, quit, and relaunch, you get only the last window back.
You need to log in before you can comment on or make changes to this bug.