Closed Bug 442426 Opened 12 years ago Closed 12 years ago

drag and drop results in picture being dropped to wrong side of desktop (NOT where it was put)

Categories

(Firefox :: Shell Integration, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 401380

People

(Reporter: alex_keel, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9) Gecko/2008061004 Firefox/3.0

under Firefox 2.xx, dragging and dropping was easy; where the mouse pointer dropped the item onto the desktop, it would be. Under V 3.x, the item "disappears" to the first available slot under pre arranged icons.  My desktop is NOT auto arranged or anything like that, and it drag and drop where I want and the item remains exactly where I dropped it.


Reproducible: Always

Steps to Reproduce:
1.open ANY webpage
2.look at photo (jpg/gif)
3.drag and drop photo
Actual Results:  
photo disappears to the closest icon on right hand side of desktop AS IF it was on "auto arrange"

Expected Results:  
Item that's been dropped should be exactly where i let go of the mouse to drop it.

I think that firefox copies correctly but the (obviously hidden) paste command does not read the system correctly, thus pasting the item to a presumed auto arranged spot.  Firefox 2.xx never did this.
I can work with it but it's slightly annoying as it did work well before.
Altogether Firefox 3 is great tho'.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401380
You need to log in before you can comment on or make changes to this bug.