vodafone.in - uses backslash character in image URIs and document.all, broken in non-IE browsers

RESOLVED INCOMPLETE

Status

Tech Evangelism Graveyard
English Other
RESOLVED INCOMPLETE
10 years ago
3 years ago

People

(Reporter: Rajesh, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

The page opens properly in Internet Explorer but not in Firefox 3. Tried opening it at three different times but to no avail.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
Login page should open.

Comment 1

10 years ago
The Vodafone image does not load because it uses backslash in the URL:
src="images\Login-vodafone__02.jpg"

Same for the My Vodafone image below it (inside the iframe).
src="images\Login_page_01.gif"

In the iframe:
http://myvodafone.vodafone.in/NWSS-Project-context-root/NwssLoginJsp.jsp?Circle=0003

There are these errors:
Warning: Non-standard document.all property was used. Use W3C standard document.getElementById() instead.
Source File: http://myvodafone.vodafone.in/NWSS-Project-context-root/NwssLoginJsp.jsp?Circle=0003
Line: 66
Error: frame is undefined
Source File: http://myvodafone.vodafone.in/NWSS-Project-context-root/NwssLoginJsp.jsp?Circle=0003
Line: 67

which is why frame.style.height="300" fails.
This why the iframe is only 150px high in Firefox and its content
is clipped to that height.

The errors are in the page, not in Firefox.

-> Evang
Assignee: nobody → english-other
Status: UNCONFIRMED → NEW
Component: General → English Other
Ever confirmed: true
Product: Firefox → Tech Evangelism
QA Contact: general → english-other
Summary: Page opening problem → vodafone.in - Page opening problem

Updated

10 years ago
OS: Windows XP → All
Hardware: PC → All
Summary: vodafone.in - Page opening problem → vodafone.in - uses backslash character in image URIs and document.all, broken in non-IE browsers
(Reporter)

Comment 2

10 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9)
> Gecko/2008052906 Firefox/3.0
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9)
> Gecko/2008052906 Firefox/3.0
> The page opens properly in Internet Explorer but not in Firefox 3. Tried
> opening it at three different times but to no avail.
> Reproducible: Always
> Steps to Reproduce:
> 1.
> 2.
> 3.
> Expected Results:  
> Login page should open.

I got your reply regarding the use of backslashes. But the thing is how does the page open fine on internet explorer? how does it resolve the same problem?

Comment 3

10 years ago
(In reply to comment #2)
> I got your reply regarding the use of backslashes. But the thing is how does
> the page open fine on internet explorer? how does it resolve the same problem?

Because IE completely disregards lots of standards that say the backslash character is not a valid path delimiter in HTML.
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 4

10 years ago
Why was this marked FIXED? The backslashes are most definitely still present, and Vodafone has not fixed anything.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 5

10 years ago
I thought it was resolved for me that the problem was with vodafone and not with firefox. But you are right. So I submitted a feedback to them regarding the same. Let's see what they do to resolve the issue.

Comment 6

7 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago7 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.