If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Force text divs to white background

RESOLVED DUPLICATE of bug 31052

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 31052
9 years ago
9 years ago

People

(Reporter: JoeS1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
Created attachment 327274 [details]
Multipart with attached html

When viewing multipart messages "inline", text parts can be obscured by styles in the html parts.

STR:
  Set view "message body as" original html
  Set view attachments inline
  Open the included eml

Result:
  The text part is partially obscured by the attachment body style.

Bug 18427 addressed this by offering the option to view message body as simple html, and it works well. But I see no "use case" to ever allow any background other than white for text divs.

The attached userContent file forces a white background for all text divs.

I propose that the affected divs be set to white natively, as the default style.

See the attached screenshot when the userContent.css is applied.
(Reporter)

Comment 1

9 years ago
Created attachment 327275 [details]
UserContent text
(Reporter)

Comment 2

9 years ago
Created attachment 327277 [details]
Screenshot after

Comment 3

9 years ago
>  But I see no "use case" to ever allow any background other than white for text divs.

The user can have set up (e.g.) white-on-black as default.

I agree it's annoying of course, but I'd say duplicate of bug 31052.
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Comment 4

9 years ago
I think bug 341059 really goes to the heart of the the problem, but dupping to 31052  Nobody wanting to touch libmime, maybe opening attachments (viewable ones)
in Tabs, might be an easier implementation.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 31052
You need to log in before you can comment on or make changes to this bug.