taobao.com - overlapping divs cause unclickable links

RESOLVED INVALID

Status

defect
RESOLVED INVALID
11 years ago
4 years ago

People

(Reporter: station.tony, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

The www.taobao.com is the most popular e-commercial website in China, and the default language of website is Chinese. The URL I provided above has many dead links right there which just be appeared by using Firefox 3 (for the old version Firefox 2, there is no problem at all!). 
The problem is like when I tried to move the mouse to the links on the left-hand side, but the mouse pointer did not shows a small hand(LINK SELECT)immediately like normal link shows. And I tried to click the link zone, still not work. I believe there something wrong with Mozilla Firefox's property. 

Reproducible: Always

Steps to Reproduce:
1.for the URL I provided, the problem like that happened all the time
2.Also I tried the other links, some of them have the same problems, but some are not. e.g. http://store.taobao.com/shop/view_shop-5eaabacdbdb8cb435101163994b26d78.htm
3.
Actual Results:  
This problem happened in the most taobao's links. 

Expected Results:  
The links right there should be clicked and opened properly.
Could you make a screenshot (e.g. in .jpg format) and indicate on that screenshot what link it not working for you? You can attach it with the "Add an attachment" link on this page.
I can confirm what he reports - the links on the left hand side of the page do not work in Firefox 3 using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0 and work fine in FF2 as well as Safari. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 3.0 Branch
Thanks Marcia. This regressed on 25 Jan 2006 probably from Bug 317375.
Blocks: 317375
Component: View Source → Layout
Product: Firefox → Core
QA Contact: view.source → layout
Version: 3.0 Branch → 1.9.0 Branch
This is invalid, because the right floating element (id="ItemCol") is overlapping the left floating element (id="ItemCol", the one with the unclickable links). See http://www.w3.org/TR/CSS21/zindex.html
The right float is after the left float in the document tree, so that's why it should be on top of the left float. Branch builds didn't do this correctly.

This could be fixed easily by giving the left floating element (id="ItemCol") a style of position: relative with it.

Note that Opera9.50 also suffers from this issue.

Moving to Tech Evangelism.
Assignee: nobody → chinese-simplified
Component: Layout → Chinese-Simplified
Product: Core → Tech Evangelism
QA Contact: layout → chinese-simplified
Version: 1.9.0 Branch → unspecified

Updated

11 years ago
Summary: CANNOT CLICK THE LINK → taobao.com - overlapping divs cause unclickable links
The site has changed of design since this issue was reported.
Closing as INVALID.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.