Firefox 3.0.x language packs should be compatible with Firefox 3.0 - 3.0.*

RESOLVED FIXED

Status

()

Firefox
Build Config
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Pike, Assigned: Pike)

Tracking

({fixed1.9.0.2})

3.0 Branch
fixed1.9.0.2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

697 bytes, patch
ted
: review+
Samuel Sidler (old account; do not CC)
: approval1.9.0.2+
Details | Diff | Splinter Review
(Assignee)

Description

10 years ago
Created attachment 327384 [details] [diff] [review]
hardcode min- and maxVersion

This is similar to what we did for Firefox 2, http://mxr.mozilla.org/mozilla1.8/source/browser/locales/generic/install.rdf#57, we should set the minVersion to 3.0 and the maxVersion to 3.0.*.

This change is zero risk, as we're not shipping language packs, but is required for localizers to test their ongoing work against stable Firefox releases.
Attachment #327384 - Flags: review?(ted.mielczarek)
Attachment #327384 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Comment 1

10 years ago
Comment on attachment 327384 [details] [diff] [review]
hardcode min- and maxVersion

This is a branch-only fix for Firefox 3, without impact to our shipped builds.
Attachment #327384 - Flags: approval1.9.0.1?

Comment 2

10 years ago
Well, uh actually, we do ship the langpacks, though they're not linked from anywhere: http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.0/win32/xpi/
(Assignee)

Comment 3

10 years ago
Duh, you could have just said that that doesn't make things risky here.

This fix is just as safe as the change we did for 2.0.0.x, which we're shipping for ages.
Attachment #327384 - Flags: approval1.9.0.1? → approval1.9.0.2?
Comment on attachment 327384 [details] [diff] [review]
hardcode min- and maxVersion

Approved for 1.9.0.2. Please land in CVS. a=ss
Attachment #327384 - Flags: approval1.9.0.2? → approval1.9.0.2+
(Assignee)

Comment 5

10 years ago
FIXED.

Checking in install.rdf;
/cvsroot/mozilla/browser/locales/generic/install.rdf,v  <--  install.rdf
new revision: 1.5; previous revision: 1.4
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed1.9.0.2
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.