table with width=100% shrinks in div with "position:absolute"

VERIFIED DUPLICATE of bug 363044

Status

()

Core
Layout: Tables
VERIFIED DUPLICATE of bug 363044
10 years ago
10 years ago

People

(Reporter: jlu, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; WOW64; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; InfoPath.2; Media Center PC 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

This works in ff 2.0.0.14 but not 3.0. 
The same issue exists with span. 



Reproducible: Always

Steps to Reproduce:
Please try the following html in FF 2 and FF 3 browsers. 
<html>
<body>
<div style="position: absolute;"> 
<table width=100% cellspacing=0 cellpadding=0 border=1> 
<tr> 
<td> aa</td> 
<td> bb</td> 
</tr> 
</table> 
</div> 
</body>
</html>
Actual Results:  
In FF 2, the table expands to take 100% of the page width
In FF 2, with=100% has no effect. 

Expected Results:  
According to html 4.01 spec in section 11.2.1 The TABLE element 
(width) - When the value is a percentage value, the value is relative to the user agent's available horizontal space. 
The behavior in FF 2 seems to be the correct one.
(Reporter)

Comment 1

10 years ago
Typo. In FF 3, with=100% has no effect.
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables
Version: unspecified → 1.9.0 Branch

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 363044
(Reporter)

Comment 3

10 years ago
This is a not dup of 363044. 
This issue is new in FF3, not reproducible in FF 2.
The issue is about html attr width=100% here, not css width:100%
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

10 years ago
(In reply to comment #3)
> This is a not dup of 363044. 
> This issue is new in FF3, not reproducible in FF 2.

Where did you get the impression that bug 363044 is related to Firefox 2?

> The issue is about html attr width=100% here, not css width:100%

There is no difference between the two as far as redering is concerned.

Comment 5

10 years ago
jlu, bug 363044 regressed after forking Fx3 from Fx2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 363044
(Reporter)

Comment 6

10 years ago
bug 363044 was logged on 2006-12-07, but I guess I was wrong that it's for FF2.

There is a sutle difference between this case and 363044. 
As it's a html attribute in this case, the width defined in html 4.01 spec (as listed above) applies, and the behavior in FF3 doesn't seem to be correct.
 
In the case of bug 363044, the css with defintion applies. The comments to the bug suggest it's not really an issue (which I agree).

So I incline to keep this issue open. But as long as this issue will be addressed, feel free to close as dup. 


Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.