Last Comment Bug 442716 - MAC Custom Keyboard Shortcuts DO NOT WORK in Firefox 3
: MAC Custom Keyboard Shortcuts DO NOT WORK in Firefox 3
Status: RESOLVED DUPLICATE of bug 429824
:
Product: Firefox
Classification: Client Software
Component: Keyboard Navigation (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-30 11:06 PDT by Vicki Brown
Modified: 2008-06-30 12:04 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Vicki Brown 2008-06-30 11:06:52 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.12pre) Gecko/20080204 Camino/1.6b3pre (like Firefox/2.0.0.12pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.12pre) Gecko/20080204 Camino/1.6b3pre (like Firefox/2.0.0.12pre)

OSX 10.5.3 leopard,system preferences allows shortcuts to be added to any application, any menu.

Shortcuts for Firefox are added as expected, show up in the menu and, when typed, the menu blinks.

However, the shortcut doesn't _work_.

Reproducible: Always

Steps to Reproduce:
1.Open System Preferences
2. Create a shortcut for Firefox "Show All History". I used cmd-Y to match Camino
3.Close System Preferences
Actual Results:  
The menu changes. cmd-Y is printed next to "Show All History". Typing cmd-Y makes the menu blink.

However, History does not appear.

Expected Results:  
Using the newly created shortcut should have the same effect as selecting the menu item with the mouse.

See http://lifehacker.com/343328/create-a-keyboard-shortcut-for-any-menu-action-in-any-program
if you don't know how to create shortcuts in Mac OS X.
Comment 2 Jo Hermans 2008-06-30 12:04:17 PDT
see bug 429824 comment 2

*** This bug has been marked as a duplicate of bug 429824 ***

Note You need to log in before you can comment on or make changes to this bug.