When FLASH is in an iFrame the left 1 pixel edge is getting cut off depending on the browser window size

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: jesse.a.brown, Unassigned)

Tracking

({flashplayer})

1.9.0 Branch
x86
Windows XP
flashplayer
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-05-05], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

In FF3 (PC) when FLASH is in an iFrame, the left 1 pixel edge of the flash piece is getting cut off depending on the browser window size. See the attached URL for an example: http://infoventions.net/ff3_test/test.htm

Reproducible: Always

Steps to Reproduce:
1.Go to a test page I have set up: http://infoventions.net/ff3_test/test.htm
2.Have the Browser in windowed mode so you have the ability to grab the corner and re-size. You can also have it maximized and see the issue, however sometimes the screen resolution is as such that you do not see it. 
3.Re-size the window. You will see the left 1 pixel edge of the flash disappear
Actual Results:  
You can see the left 1 pixel edge of the Wmode=Transparent FLASH disappear depending on browser window size.

Expected Results:  
Not cut off the flash

This problem only seems to occur when the content is centered or needs to be re-rendered as the window is re-sized. 

I noticed that if the flash is set to Wmode=Window that the problem does not present itself, however you can see the issue when it is either Transparent or Opaque. I have set up the test page with a Transparent and Window version.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
(Reporter)

Updated

10 years ago
Keywords: flashplayer

Updated

9 years ago
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: 3.0 Branch → 1.9.0 Branch

Comment 1

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.4) Gecko/20100413 Firefox/3.6.4
It works for me. Reporter, Please update if you are able to still reproduce with the latest nightly build  ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/
Whiteboard: [closeme 2010-05-05]
(Reporter)

Comment 2

9 years ago
You are correct. I can no longer reproduce this bug with the latest version of FF. Changing status of Bug. Thanks for taking a look.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.