If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bookmarks saving the wrong URL in certain conditions

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: CJ Smith, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-GB; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-GB; rv:1.9) Gecko/2008061004 Firefox/3.0

Several bookmarks that I have recently saved bring up incorrect pages when I re-select them at a later date. I think I have figured out the conditions this occurs. See 'Reproducibility'.

Reproducible: Always

Steps to Reproduce:
1.Save a bookmark, either with Cmd-D, or by dragging to the Bookmark toolbar.
2.While still in the current tab, with the bookmarked page, load a new webpage (from the address bar)
3.Quit and re-launch Firefox.
4. Launch a new tab and try and load the bookmark. Instead of being the intended saved URL, you will get the page subsequently loaded into the tab. 
Actual Results:  
The retrieved bookmark was the page most recently viewed in the tab that was bookmarked, not the intended saved bookmark.


I have Foxmarks installed, but this is happening before any Foxmarks sync has taken place, so I don't think they're to blame.

I also have the TabsMixPlus extension installed, although I don't know how this might affect things.
(Reporter)

Comment 1

9 years ago
Has no one else not had a problem with this??
(Reporter)

Comment 2

9 years ago
Ok, I think this must have been due to some corruption in my bookmarks database. I noticed the problem was only occuring on one of my Macs, so I completed deleted the Places.sql file and all bookmark related files from my profile folder. I then rebuilt them using a download from Foxmarks and it's been fine ever since.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.