Refresh button doesn't refresh PDF page.

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: rust710, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Clicking the refresh button does not cause the PDF page displayed inline via the Adobe browser plug-in. to be refreshed. This worked in all the versions of Firefox 2 I used.

The PDF is generated by a php script on an Apache server that updates frequently.

I can go back and click the link to it again, but it's annoying.

Reproducible: Always

Steps to Reproduce:
1.Start Firefox
2.Goto a PDF web page
3.Press the refresh key
Actual Results:  
PDF page does not refresh

Expected Results:  
PDF page refreshes.

The provided URL is similar to the PDF file I am having trouble with.

I am using version 8.1.0 2007-05-11 of the Adobe Plug-in.

I'll test this in Linux as soon as I figure out how upgrading to Firefox 3 broke my Adobe Plug-in...
(Reporter)

Comment 1

11 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0

Works properly on Linux. However on Linux my Adobe plugin is Version 8.1.2 01/15/2008.
Version: unspecified → 3.0 Branch

Comment 2

11 years ago
Update the Adobe plugin version and try it. 
(Reporter)

Comment 3

11 years ago
Upgrading to 8.1.2 on Windows did not solve the problem. I was not able to make Adobe 9.0 not crash Firefox, and it didn't run long enough for me to know if it solves the problem.

Comment 4

9 years ago
In my experience this bug is still actual.

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
with actual Abode Reader Plugin

Dynamical generated PDF report based on the Request-parameters.

PDF-files from the same URL (request-parameters with http-post) are treated as the same, though the content is different, until the first one is closed, which means it could be overwrited in the plugintmp-folder, cause its ment to be the same.

I am not sure if this is an Adobe or mozilla issue.

Comment 5

9 years ago
(In reply to comment #4)
> In my experience this bug is still actual.
> Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.3) Gecko/2008092417
> Firefox/3.0.3
> with actual Abode Reader Plugin
> Dynamical generated PDF report based on the Request-parameters.
> PDF-files from the same URL (request-parameters with http-post) are treated as
> the same, though the content is different, until the first one is closed, which
> means it could be overwrited in the plugintmp-folder, cause its ment to be the
> same.
> I am not sure if this is an Adobe or mozilla issue.

Sorry i missed the most important thing:

PDF-files from the same URL * with the same content-length * ...
This is a mass search for Firefox General bugs filed against version 3.0 that are UNCO and have not been changed for 200 days.

Reporter, please update to Firefox 3.6.10 or alter. Firefox 3.0 is no longer supported and is no longer receiving updates. After you update, please create a fresh profile, http://support.mozilla.com/kb/managing+profiles, and test to see if your bug still exists. If you still the bug, then please post a comment with the version you tested against, and the problem. If the issue is no longer there, please set the RESOLUTION to  RESOLVED, WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 8

8 years ago
I don't really know when this got fixed, but I can confirm it is fixed. Firefox 3.6.12, Adobe Reader 8.2.5

Thanks!
Resolution: INCOMPLETE → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.