Expand scope of SUMO to include people on twitter/blogs etc.

VERIFIED INCOMPLETE

Status

support.mozilla.org
General
--
enhancement
VERIFIED INCOMPLETE
10 years ago
10 years ago

People

(Reporter: tom, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
Get Satisfaction features a really awesome thing that I'm currently demonstrating the use of thanks to the trust of David Ascher.

Here's a sample topic where I saw a user didn't like Firefox because it lacked two features which he had simply overlooked:
http://getsatisfaction.com/mozilla/topics/how_do_i_put_the_tab_bar_at_the_bottom_and_disable_spell_check

Bug 442537 was filed because of overheard.

I got more information on bug 405141 and bug 426780 via overheard:
http://getsatisfaction.com/mozilla/topics/logmein_not_working_with_firefox_3

I think that if SuMo had a way for users to create forum topics or otherwise receive more official help via twitter, there is already a user providing some help, http://twitter.com/firefox_answers (whom I will use the pronoun "he" for, but I do not know the user's gender), and currently users love it:
http://summize.com/search?q=to%3Afirefox_answers+Thanks

He's not always up to date on the best methods, and is actually using trademarked images in such a fashion that he confuses users into thinking he is official: http://twitter.com/realjames/statuses/846636975

Thus, I think SuMo could provide an interface similar to Get Satisfaction's "Overheard" feature in order to provide assistance to users who, instead of looking for support, switch back to something that works, be it Internet Explorer, Safari, Avant Browser, or even Firefox 2 (which I see quite a bit, and not just because extensions aren't updated).  I think that in the bigger "browser war", customer retention is just as important as gaining customers.  Happy customers, especially those who receive unexpected help (see the responses to firefox_answers above), are the best forms of advertising.  Telling their friends "I had a problem, and a mozilla representative found me and helped me out!" is much better than an ad on a webpage.
(Reporter)

Updated

10 years ago
Alias: overheard

Comment 1

10 years ago
Hey Tom -- I'm not sure what "Overheard" actually is. It looks like a normal forum thread, which is already supported on SUMO. What exactly are we missing? :)

(100% agree about retention, happy customers, and exceeding user's expectations.)
(Reporter)

Comment 2

10 years ago
Sure.  Overheard is described in detail in this blog post:
http://blog.getsatisfaction.com/2008/05/22/two-big-releases-help-center-overheard/

But the jist is, it scans twitter conversations using the summize.com API for mentions of Firefox, Thunderbird, Mozilla, or whatever other keywords you want to add (but those are the ones I'm using).  You can see it in action here:
http://getsatisfaction.com/mozilla/overheard

The issue is, this is purely unofficial. Lucy wants to condense everything onto support.mozilla.com, and I think that the big loss of just using support.mozilla.com is that users have to come here.  With Overheard on Get Satisfaction, I go to the user directly.  The net result is the user sees that Mozilla Cares, and the situation gets resolved.  In comment 0, I listed a few examples of where I took unhappy or confused twitter posts (tweets) and turned them into support threads.

However, people aren't just complaining about Firefox on Twitter (of course), but for now there is a method we can use (the summize.com api) to get those posts and manage them.

Also, a neat feature would be if I could go through these overheard tweets and mark them as what they are, because sometimes I will see people just saying "I love awesomebar!" or "I love firefox 3!", and it would be cool to be able to tag posts as praise for a mozilla product, we could then use those praise-tweets as a little testimonials box.

I'd be happy to clear anything up in e-mail, or on IRC (I joined #sumo, and you said you're in a meeting, so I posted the details here).
(In reply to comment #2)

> The issue is, this is purely unofficial. Lucy wants to condense everything onto
> support.mozilla.com, and I think that the big loss of just using
> support.mozilla.com is that users have to come here.

That's not what I said.

What I DID say was that right now we're still working on making the core sections that we've got already great and that for now it isn't the best use of the SUMO team's time to keep expanding and adding new functions to the site before existing ones are up to the standard we want them to be.

Part of the reason for having official documentation is so that anyone can use it. Right now anyone can help users receive "official" support simply by linking to our articles, or using information from them to support users. You're doing that right now on Twitter and I don't see any reason why you and other community members shouldn't keep doing it.
I've filed a related bug 443204 for similar functionality regarding blogs.

Comment 5

10 years ago
Can we broaden the scope of this bug a little?  I think the central discussion is should we expand the scope of SuMO to be more than just people who come to us needing help but also to actively scan Twitter/blogs/etc for users' issues with Firefox and try to help them proactively or at least for getting feedback.

While we can always help people however we find people needing help (I post comments in LifeHacker posts all the time) the question is whether this should become part of the mission of SuMO or if it should be more a marketing/PR thing.  Testimonials especially should be a PR thing and not sumo.  Also, what about other support channels, would we also be expanding to support the MZ forums or other support forums?  How are they different from a bunch of blog posts?

Comment 6

10 years ago
Ok, I'm retitling the bug.  This may also be a valid discussion point for the newsgroup.
Summary: "Overheard" like twitter/etc interface for customer support/retention → Expand scope of SUMO to include people on twitter/blogs etc.

Updated

10 years ago
Duplicate of this bug: 443204
(Reporter)

Comment 8

10 years ago
Retitling again in case someone searches retention, because that's really what this is, keeping people using Firefox
Alias: overheard → retention
Summary: Expand scope of SUMO to include people on twitter/blogs etc. → Customer Retention - Expand scope of SUMO to include people on twitter/blogs etc.

Comment 9

10 years ago
No need for the "retention" bit. It's a given and goes without saying on all Support bugs.
Alias: retention
Summary: Customer Retention - Expand scope of SUMO to include people on twitter/blogs etc. → Expand scope of SUMO to include people on twitter/blogs etc.

Comment 10

10 years ago
This is a very interesting discussion, but before we have any solid plans, it should really be held in the newsgroup or contributor forum. I'm resolving this bug for now, but we can always reopen once we formalize it into a concrete plan.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Resolution: INVALID → INCOMPLETE
If no decision has been made on the bug, the bug shouldn't be resolved. INCOMPLETE is better than INVALID but still doesn't apply.
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---

Comment 12

10 years ago
There is no bug here, it's a discussion. Let's have it outside bugzilla. Resolving again...
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → INCOMPLETE

Comment 13

10 years ago
http://groups.google.com/group/mozilla.support.planning/browse_thread/thread/fd3dcba12e920006#
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.