Continue button on this form doesn't give results

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: steve.beitzel, Assigned: karnaze)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
The URL results in a table of Realtors in the San Francisco area.
Since there are more than 10 and the script only displays ten
listings at a time, there's a button at the bottom of the table
for displaying the next 10 agents. With Navigator 4 or with IE 4,
clicking on this button will show another results page, with items
11 through 20. Gecko shows a results page with a next and previous
button, but with no results table.

Steps to reproduce:
1. Launch apprunner.exe
2. Go to the URL
3. Click on the button labeled "Next 10 Agents"

Build/System information:
Windows NT 4, service pack 3
Build 99032914, built with VC++ 6

Comment 1

20 years ago
... any chance this is another problem with URLs that end in .asp? I vaguely
remember other problems with submissions to .asp URLs...
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

20 years ago
The problem was an <input> as a child of a <table>. Here is the test case for
regression testing.

<FORM METHOD="GET" ACTION="http://search.yahoo.com/bin/search"
NAME="searchform">
<TABLE border=1>
 <TR>
  <td> <INPUT TYPE=HIDDEN NAME="zip2" VALUE = "">foo</td></tr>
</table>
<input type=submit name=submit>
</form>

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 3

20 years ago
seems fine to me now using the 1999042608 build. btw, good luck with the name
change over there at homeshark, and thanks for filing this!
You need to log in before you can comment on or make changes to this bug.