Weave Installer and options sheets don't work with Google Toolbar

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: ty5oina02, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Weave/0.2

I downloaded Weave and installed it, but the installer didn't start when I restarted Firefox. I tried using the Tools -> Weave -> Preferences menu item, but clicking there would have no effect: I was expecting the Preferences Sheet to open up, but nothing happened.

I suspected one of my Firefox add-ons or extensions to be causing a conflict with Weave so I disabled them one by one, restarting Firefox after each change. Eventually, I was able to pinpoint Google Toolbar for Firefox 3.1.20080605W as being the problem. If I disable it and restart Firefox, the installer wizard automatically starts. If I cancel out, reenable the toolbar and restart Firefox, the installer doesn't start.

After I went through the Weave setup wizard and synced my profile, I reenabled the google toolbar. It looks like the sync is working, but I still can't open the Preferences sheet by choosing the Tools -> Weave -> Preferences menu item.

Reproducible: Always

Steps to Reproduce:
1. Enable Google Toolbar for Firefox 3.1.20080605W
2. Restart Firefox
3. Select Tools -> Weave -> Preferences
Nothing happens.

1. Disable Google Toolbar for Firefox 3.1.20080605W
2. Restart Firefox
3. Select Tools -> Weave -> Preferences
I see the Preferences sheet.
(Reporter)

Comment 1

10 years ago
I've found a workaround for now, which is to use the Tools -> Options menu item and then choose the Weave tab to update Weave Preferences.
Severity: major → normal

Comment 2

10 years ago
I've just run into the same problem on Ubuntu Linux 8.04 using a 64-bit build of weave (built as per bug 442679).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

10 years ago
As Samir said that is the only workaround to show anything of Weave.  Hopefully the next fix will correct this as I like having my Google TB with one click access to my Gmail instead of making a bookmark to my Gmail.

Comment 4

10 years ago
I also have this problem with Weave 0.2.4 on Windows XP SP2, Windows XP SP3 and Kubuntu Linux 8.04 (32 bit).

Comment 5

10 years ago
Getting the same results with Firefox 3.1, Weave 0.2.5 under Mac OS X Leopard 10.5.4, as well as Windows XP SP3.  Definitely does not look like it is tied at all to one particular OS, just Google Toolbar.

thanks for the hard work!

Comment 6

10 years ago
By now I'm using the Google Toolbar 3.1.20080605L, Firefox 3.0.1 and Weave 0.2.6. And it works again! At least on Windows XP SP3 and Kubuntu Linux 8.04 32 bit. I couldn't test it yet on Windows XP SP2. I've had this problem until Weave 0.2.5, v0.2.6 seems to have fixed it.

Comment 7

10 years ago
I can't think of what we could've possibly changed in 0.2.6 to have that effect.  I guess some of the Thunderbird integration stuff, dmose?

Comment 8

10 years ago
yeah it looks like v0.2.6 resolved the issue on Leopard as well 10.5.4.

Comment 9

10 years ago
It's certainly possible, though I'm not sure exactly which change would have done it.

Comment 10

10 years ago
Well, closing as worksforme.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.