If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Selecting an iMip/iTip email when writable WCAP calendars in the calendar list causes error output

RESOLVED DUPLICATE of bug 442392

Status

Calendar
Provider: WCAP
RESOLVED DUPLICATE of bug 442392
9 years ago
9 years ago

People

(Reporter: Andreas Treumann, Assigned: dbo)

Tracking

unspecified
Bug Flags:
blocking-calendar0.9 +

Details

(Reporter)

Description

9 years ago
STEPS TO REPRODUCE:
===================

- create a wcap calendar
- check that this one is writable
- go to mail mode
- open a mail with an iMip/iTip attachment 

RESULT:
=======

- error console output:

Error: [context-id: 6374aaaa-d2c3-40dd-815e-1cfa0619fef5, uri: https://cal-emea.sun.com/, userId=at93795, default calendar]
error: READ_FAILED
stack:
1: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapUtils.js:167] logError
2: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapCalendar.js:71] calWcapCalendar_notifyError_
3: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapCalendar.js:88] calWcapCalendar_notifyError
4: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calProviderBase.js:183] cPB_notifyOperationComplete
5: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapCalendarItems.js:1067] getItem_resp
6: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapRequest.js:181] calWcapRequest_execRespFunc
7: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapRequest.js:196] calWcapRequest_execSubRespFunc
8: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js:723] issueNetworkRequest_resp
9: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapRequest.js:194] calWcapRequest_execSubRespFunc
10: [file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapSession.js:749] netResp

Source File: file:///C:/Documents%20and%20Settings/at93795/Application%20Data/Thunderbird/Profiles/bigaf98i.default2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calWcapUtils.js
Line: 167

EXPECTED RESULT:
================

- no errors

REPRODUCIBLE:
=============

- always

You get this error for all writable marked wcap calendars (own/subscribed). Mark all calendars 'read only' -> no error occurs
(Assignee)

Comment 1

9 years ago
dupe to bug 442392?
Flags: blocking-calendar0.9+
(Assignee)

Comment 2

9 years ago
ought to be fixed with that bug
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 442392
You need to log in before you can comment on or make changes to this bug.