Flash 9 in FF3 crashes on this web page trying to load a movie

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: jsquareg, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Here is a problem that was posted over in Mozilla.Support.Firefox on June 24 
entitled "FF3 Crashes on this Webpage."  It has been thoroughly thrashed out 
there but with no solution.  I bring it here seeking a solution because 
there seems to be a conflict between FF3 and Win XP.  I am not the OP and I 
hope by bringing it here I have not offended this NG or 
Mozilla.Support.Firefox in any way.

Briefly, the problem is that this site http://www.ramonadisposal.com causes 
a crash in Firefox and produces an error message saying,"Firefox has 
encountered a problem an needs to close...." The error signature is:

    AppName: firefox.exe
    Appversion 1.9.0.3071 ModName ntdll.dll
    ModVer 5.1.2600.5512

and seems to occur when Flash Player tries to show the large image in the 
upper right corner of the site. The small image on the left displays 
correctly.

Now for the specifics.

I have Firefox 3 installed on my Laptop and my desktop.  Both are running XP 
Home SP3 and Adobe Flash Player 9.0.124.0. The laptop renders the site just 
fine but the desktop produces the error above.  I installed Firefox on both 
machines from my administrative account (MAIN). If I go to this site while 
running as MAIN the error occurs.  HOWEVER, if I switch to the guest account 
or any other account including the Administrator, the site renders with no 
problems. That seems very strange to me.

What I have done:

I have compared the Firefox prefs.js and user.js files on both machines and 
they are identical.

I have used the FF Profile manager to run FF on the desktop with the 
laptop's profile but the problem still exits.

I have deleted FF on the Desktop and installed it again.  No luck

Running FF in the safe mode (firefox.exe -safemode) doesn't solve the 
problem.  Likewise, booting XP into safe mode doesn't either.

Will someone please give me some help on getting FF to display this site 
correctly from my MAIN account on the desktop.

Thank you very much. 



Reproducible: Always

Steps to Reproduce:
1.Simply go to www.ramonadisposal.com
2.
3.
Actual Results:  
I get the system error message state above

Expected Results:  
Web page displays the image(movie)

Comment 1

10 years ago
Due to bug 422308, Flash prevents the Mozilla crash reporter from coming up, so you could try disabling it in the add-ons manager and see if it crashes afterwards.  However, my guess is that the Flash plugin is what's crashing here.  In order to get a stacktrace for us to work with you'll probably need to try this:
http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg

You could also give Flash 10 beta a try as it lacks this bug and might not crash, however it's not final and doesn't work correctly with everything yet.
http://labs.adobe.com/downloads/flashplayer10.html
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Due to bug 422308, Flash prevents the Mozilla crash reporter from coming up, so
> you could try disabling it in the add-ons manager and see if it crashes
> afterwards.  However, my guess is that the Flash plugin is what's crashing
> here.  In order to get a stacktrace for us to work with you'll probably need to
> try this:
> http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg
> 
> You could also give Flash 10 beta a try as it lacks this bug and might not
> crash, however it's not final and doesn't work correctly with everything yet.
> http://labs.adobe.com/downloads/flashplayer10.html
> 

Thank you.  The Flash 10 (Beta) corrected the problem and I can live with that for a while until the real thing comes out.  However, I still don't understand why the webpage displayed correctly when logged in to the XP 'Guest' account.  Any thoughts on that.

Comment 3

10 years ago
You'd have to ask Adobe about that.  I really don't know.

Just to be clear, please be warned that there will be sites that don't work correctly with the beta and you may need to re-install Flash 9 to use them.  Also, don't forget to update to Flash 10 final when it comes out.

Closing as INVALID as this is apparently a Flash crash and not a Mozilla bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Summary: FF3 Crashes on this web page trying to load a movie → Flash 9 in FF3 crashes on this web page trying to load a movie
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.