If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Changing Products with Strict Isolation fails when the CC list changes at the same time

RESOLVED FIXED in Bugzilla 3.2

Status

()

Bugzilla
Creating/Changing Bugs
--
major
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Alex Eiser, Assigned: Alex Eiser)

Tracking

({regression})

3.1.4
Bugzilla 3.2
regression
Bug Flags:
approval +
approval3.2 +
blocking3.2 +

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15
Build Identifier: Bugzilla 3.1.4

If you change a bugs product, and strict isolation is on you get an error about not being able to access the CClists as objects.

2 different ways to fix it... attached is one option.




Reproducible: Always

Steps to Reproduce:
Steps:
1) Create a bug in product X
2) modify it to be in product Y. Add some one to the CC list.
3) Save. See failure.

Actual Results:  
[Thu Jul 03 16:59:46 2008] [error] [client 127.0.0.1] Can't call method "id" without a package or object reference at Bugzilla/Bug.pm line 1453., referer: http://localhost/bugzilla/process_bug.cgi
[Thu Jul 03 17:00:42 2008] [error] [client 127.0.0.1] Can't locate object method "id" via package "TestProduct" (perhaps you forgot to load "TestProduct"?) at Bugzilla/Bug.pm line 1458., referer: http://localhost/bugzilla/process_bug.cgi

Expected Results:  
record save sucessfully
(Assignee)

Comment 1

9 years ago
Created attachment 328073 [details] [diff] [review]
Possible patch for error with strict issolation
Attachment #328073 - Flags: review?

Comment 2

9 years ago
This is a regression. I cannot reproduce the bug in 3.0.4, but I can on tip.
Assignee: general → create-and-change
Status: UNCONFIRMED → NEW
Component: Bugzilla-General → Creating/Changing Bugs
Ever confirmed: true
Flags: blocking3.2+
Keywords: regression
OS: Mac OS X → All
Hardware: PC → All
Target Milestone: --- → Bugzilla 3.2
Version: unspecified → 3.1.4

Comment 3

9 years ago
Comment on attachment 328073 [details] [diff] [review]
Possible patch for error with strict issolation

Nice catch. r=LpSolit
Attachment #328073 - Flags: review? → review+

Updated

9 years ago
Assignee: create-and-change → aeiser
Flags: approval3.2+
Flags: approval+
(Assignee)

Comment 4

9 years ago
It burned us... so when I patched it I figured I should share. :)

Comment 5

9 years ago
tip:

Checking in Bugzilla/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.246; previous revision: 1.245
done

3.1.4:

Checking in Bugzilla/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.241.2.3; previous revision: 1.241.2.2
done
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.