Flash crashes Firefox when connecting to website using adobe connect

RESOLVED WORKSFORME

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED WORKSFORME
10 years ago
2 years ago

People

(Reporter: michael.jordan@unico.com.au, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Going to https://admin.adobe.acrobat.com/_a300965365/p25766209/ crashes the browser

Reproducible: Always

Steps to Reproduce:
1. Browse to https://admin.adobe.acrobat.com/_a300965365/p25766209/
2.
3.
Actual Results:  
Firefox crashes. The program exits and all windows are exited

Expected Results:  
Website loads. If there is a problem with adobe flash itself, Firefox should handle/report the error and not display the page. ie: is should not crash.

The flash plugin shows as version 9.0 r28 in firefox

Comment 1

10 years ago
Current Flash version is 9.0 r124.  Update.
(Reporter)

Comment 2

10 years ago
Updated to 9.0 r124. Problem remains. Also, even if there is a problem with a plugin, this should not crash firefox. Firefox should deal with plugin errors gracefully and not crash every window when a page fails to load.

Comment 3

10 years ago
Unlike an extension, a plugin is a compiled binary blob, often closed-source as in the case of Flash.  Sadly, Mozilla has no control over what Adobe does there, and if they crash there's not much anyone can do about it.

I would normally ask that you disable the Flash plugin to see if it still crashes, however the page in question is all Flash.  You could try the page in Firefox safe mode with other plugins disabled to make sure it's really Flash crashing here.
http://support.mozilla.com/en-US/kb/Safe+Mode
You could also try a new profile:
http://support.mozilla.com/en-US/kb/Managing+Profiles

There's also the issue of the bug in Flash that breaks the Mozilla crash reporter which we would normally use to figure out what's broken here.  (bug 422308)

The last thing to try would be the beta of Flash 10:
http://labs.adobe.com/downloads/flashplayer10.html

It does have fixes for many crashes some people get with Flash 9, however it is beta and does not work for every website out there.  Especially because this is happening on an Adobe site, any other help would require that you contact Adobe.
(Reporter)

Comment 4

10 years ago
Flash 10 seems to fix the issue. Interesting that you can't catch crashes from plugins. No catch(Exception E) in this case I guess :)

Thanks for the assistance. Sorry for bothering you with something you can't fix!

Comment 5

10 years ago
We can normally catch crashes from plugins in the crash reporter to be analyzed, however Flash 9 has a rather large bug that prevents this.  (bug 422308)  Sadly no, we can't just catch any problems in plugins and prevent them from killing the larger app, though yeah, I really wish we could.  ;)

In any case, I'm glad your problem is fixed.  Please remember that you might need to downgrade back to Flash 9 for certain sites to work correctly, and you'll also need to remember to upgrade to Flash 10 final when it comes out.

Closing as INVALID, as this is apparently a Flash bug and not a Mozilla bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Keywords: crash
Summary: Firefox crashes when connecting to website using adobe connect & flash → Flash crashes Firefox when connecting to website using adobe connect
Version: unspecified → 3.0 Branch

Updated

10 years ago
Component: General → Plug-ins
Product: Firefox → Core
Version: 3.0 Branch → Trunk

Updated

8 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: general → adobe-flash
Resolution: INVALID → WORKSFORME
Target Milestone: --- → Jul 2008
Version: Trunk → 9.x

Comment 6

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Target Milestone: Jul 2008 → ---
Version: 9.x → unspecified
You need to log in before you can comment on or make changes to this bug.