[gu-IN] Add gujaratilexicon.com as default dictionary for Gujarati build of Firefox

RESOLVED FIXED

Status

Mozilla Localizations
gu-IN / Gujarati
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Kartik Mistry, Assigned: Ankit Patel)

Tracking

({fixed1.9.1})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

As mentioned by Pike in https://bugzilla.mozilla.org/show_bug.cgi?id=403020 I am reporting this as new bug.

We need to add site http://www.gujaratilexicon.com as default dictionary search engine for Gujarati Firefox build. Permission from site is already granted for usage for this. See Bug 403020 for permission email from Ashok Karania.

Reproducible: Always

Actual Results:  
Currently, there are no dictionary for Gujarati build is added.

Expected Results:  
Dictionary search should give result using gujaratilexicon.com
Assignee: nobody → ankit644
Component: Search → gu-IN / Gujarati
Product: Firefox → Mozilla Localizations
QA Contact: search → ankit644
(Assignee)

Comment 1

10 years ago
Created attachment 328651 [details]
gujaratilexicon dictionary for english-gujarati dictionary search...

Hi Axel,

I have tried to create the gujaratilexicon.xml file after looking into other language dictionary search files as well english search file answers.xml file. Could you please check whether it's correct or not?

Kartik, I didn't add <Image> tag into this XML file, which is used for grabbing the url-logo-icon I guess, that's not available for Gujaratilexicon.com. Let me know, if they do have anything like this. I will get it added to the xml file.

Thanks!
Ankit Patel

Comment 2

10 years ago
The permission is in bug 403020 comment 18.

Mic, what do you think, should we add gujaratilexicon.com in a minor update on 3.0.x?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

10 years ago
yes, that'd be great.

Comment 4

10 years ago
Comment on attachment 328651 [details]
gujaratilexicon dictionary for english-gujarati dictionary search...

We should move the query params to <Param /> elements with "  " indention. If you want help with that, just poke me.

Mic is going to poke for an icon to use for this, too.
Attachment #328651 - Flags: review-
(Reporter)

Comment 5

10 years ago
I have attached required icon for GujaratiLexicon.com Search Engine. Please find it in attachment.

Thanks.
(Reporter)

Comment 6

10 years ago
Created attachment 328851 [details]
Icon for GujaratiLexicon.com Search Engine

Comment 7

10 years ago
Thanks! this is authorized by GujaratiLexicon as well (received in email today)
(Assignee)

Comment 8

10 years ago
Hi Pike/Mic,

The xml file I added as an attachment 328651 [details] is correct?

If not, please let me know, what should I modify in it. Let's make this fixed!

Thanks!
Ankit

Comment 9

10 years ago
Hi Ankit,

the attached version is broken. There are a few '&' which break XML parsing. Not that we need them if we go for <Param> elements, see comment 4.

The Image should be included, too, see the data uri kitchen at http://software.hixie.ch/utilities/cgi/data/data for help on converting attachment 328851 [details].
(Assignee)

Comment 10

10 years ago
Hi Axel,

Frankly, I don't understand the XML file format and have no idea how to edit it. Just checked the other language files and tried to edit it that way, but didn't know that it could break the things. Could you please make a patch for this?

Comment 11

10 years ago
Gandalf, can you help out with fixing the attached patch to address my comments in comment 9? Thanks.
Whiteboard: needs-patch
Created attachment 335509 [details] [diff] [review]
Search plugin with icon and <Param/> elements

Maybe I can help :)

I created the patch against https://hg.mozilla.org/l10n-central/gu-IN/. The query parameters are now in separate <Param/> elements, I fixed one ampersand in <SearchForm/> and added the icon from attachment 328851 [details].

Note this line:
+  <Param name="dictype" value="EG"/>
It means that the dictionary accepts English words and returns Gujarati translation. I copied this behavior from Ankit's plugin, but in bug 403020 the discussion focused on a Gujarati-English dictionary, not an English-Gujarati one. Ankit, can you confirm that English-Gujarati is what you want? 

Also, the dictionary website uses some AJAX to display results under the search form without a reload, and consequently when you search using the plugin, you'll only see the results table with is normally fetched by AJAX, and not the complete results page. Compare http://www.gujaratilexicon.com/index.php?action=Ajxdictionary&mode=search&type=1&dictype=EG&sitem=sky (plugin search) and http://www.gujaratilexicon.com/index.php?action=dictionary&chngdictype=EG (type 'sky') to get an idea of what I mean. I think that the added value is still decent, but I'd like to know what Mic and Axel think about it. Thanks!
Attachment #328651 - Attachment is obsolete: true
Attachment #335509 - Flags: review?(l10n)
(Assignee)

Comment 13

10 years ago
Hi Stats,

Thanks a bunch for helping us out here with creating the patch...!
Ankit, no problem :) BTW. what do you think about the question below?

(In reply to comment #12)
> Note this line:
> +  <Param name="dictype" value="EG"/>
> It means that the dictionary accepts English words and returns Gujarati
> translation. I copied this behavior from Ankit's plugin, but in bug 403020 the
> discussion focused on a Gujarati-English dictionary, not an English-Gujarati
> one. Ankit, can you confirm that English-Gujarati is what you want? 
(Assignee)

Comment 15

10 years ago
Stats, Yes, I wante English-Gujarati. Confirmed!

Thanks!

Comment 16

10 years ago
Comment on attachment 335509 [details] [diff] [review]
Search plugin with icon and <Param/> elements

Ankit, Stas, can you contact Ashok Karania with two questions here?

First, if there is a URL to use that corresponds to the full output, not just the sub-table.

Secondly, I'm confused about the site's encoding. It sends utf-8 in the http header, and iso-8859-1 in the meta tag in the page.
(Assignee)

Comment 17

10 years ago
Pike,

As per my latest conversation with Kartik, they are working on this issue and will let's know soon...

Here is the chat conversation I had with Kartik on #mozilla.in
-----
<ankit> kart_: ping
<kart_> ankit: pong
<ankit> kart_: need your help buddy! :)
<kart_> ankit: ask
<ankit> https://bugzilla.mozilla.org/show_bug.cgi?id=443543
<kart_> ankit: regarding pike's mail?
<ankit> Comment #16
<kart_> ankit: point 2 will be fixed soon. Point  1 too, we are making pretty CSS for table result
<ankit> kart_: could you please update the bug as well, will help others to understand the status of the bug
<kart_> ankit: let me get final report from developers who are working on GL.com, I will update it soon
<ankit> kart_: no probs, thx
------
Hey Kartik, thanks for the update. 

The table indeed looks much better now. However, because of the AJAX-like nature of the search initiated on the site, we're still getting only the table with results without the search box, when searching from the search bar in Firefox.

Do you think there is an easy way on your side to add this search box if the search has been originated from the search box?
Created attachment 336551 [details]
Missing search box on the result page

The screen shot of the search box I'm referring to above.

(also: s/has been originated/originates)
(Assignee)

Comment 21

10 years ago
Kartik, Ping...

Updated

10 years ago
Attachment #335509 - Flags: review?(l10n) → review-

Comment 22

10 years ago
Comment on attachment 335509 [details] [diff] [review]
Search plugin with icon and <Param/> elements

That link is a 404 now, I think. r-
(Reporter)

Comment 23

10 years ago
Axel, Let me know which link is 404. What I can do from my side..

Comment 25

10 years ago
Comment on attachment 335509 [details] [diff] [review]
Search plugin with icon and <Param/> elements

oh, right, there was an extra gujaratilexicon in the sample url, which isn't in the plugin. So r=me on that.
Attachment #335509 - Flags: review- → review+
Thanks Pike. Let's target this change for 3.1 release (and leave the set of the search plugins in 3.0.x as it right now).

Ankit, do you want to check this in? I'll be happy to help with it, too. Just let me know.
(Assignee)

Comment 27

10 years ago
(In reply to comment #26)
...
> Ankit, do you want to check this in? I'll be happy to help with it, too. Just
> let me know.
...

Which branch(3.0/3.1/3.2) and VCS(CVS/hg) you want me to check in?
Adding (or removing) web services should only happen between major releases, so let's leave 3.0.x out. Please commit to 3.1 branch (http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/gu-IN) and 3.2 (http://hg.mozilla.org/l10n-central/gu-IN). Thanks!
(In reply to comment #29)
> Done!

Thanks Ankit.

> 
> Fx 3.1:
> http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/gu-IN/rev/50681f26c1f3

This looks good.

> 
> Fx 3.2: http://hg.mozilla.org/l10n-central/gu-IN/rev/261f47df234d &
> http://hg.mozilla.org/l10n-central/gu-IN/rev/0d1a2b3716d9

This however was commited to the GECKO191b2_20081125_RELBRANCH branch, and it should have gone to 'default'. You'll need to back out this change, then do 'hg up default' (which will switch the branch to 'default'), and commit again. This commit will create a new head, which is normal ('hg heads' should list two heads, one in the 'default' branch and the other one in the GECKO191b2_20081125_RELBRANCH branch). I'm on IRC if you need any help. Thanks!

When you fix this, please close this bug and add the 'fixed1.9.1' keyword.
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed1.9.1
Resolution: --- → FIXED
(Assignee)

Comment 31

10 years ago
Thx Pike, Stats for helping me with this correction...
No problem, I'm glad we were able to help. Good work!
Whiteboard: needs-patch
(Reporter)

Comment 33

10 years ago
Thanks to all for making this possible. Kartik on behalf of GujaratiLexicon Team.
(Reporter)

Comment 34

10 years ago
Here is patch to Show SearchBox in GujaratiLexicon.com once you have searched word using searchplugin. Please accept and add this after review.
(Reporter)

Comment 35

10 years ago
Created attachment 357612 [details] [diff] [review]
Patch to show searchbox in GujaratiLexicon.com after searching word using searchplugin

Updated

10 years ago
Attachment #357612 - Flags: review?(stas)
As this bug has already been resolved, I filed a new one regarding updating the "action" parameter: bug 474409. The review and implementation should happen there.

Thanks Kartik for making this change!
Comment on attachment 357612 [details] [diff] [review]
Patch to show searchbox in GujaratiLexicon.com after searching word using searchplugin

Moved the review over to bug 474409.
Attachment #357612 - Flags: review?(stas)
You need to log in before you can comment on or make changes to this bug.