<Ctrl+Shift><NumPad4-6> while focus in textbox does not mark text; instead, moves tab focus.

RESOLVED WONTFIX

Status

()

Firefox
Keyboard Navigation
--
minor
RESOLVED WONTFIX
10 years ago
a year ago

People

(Reporter: Al Savage, Unassigned)

Tracking

2.0 Branch
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.1.15) Gecko/20080622 PmWFx/2.0.0.15
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.1.15) Gecko/20080622 PmWFx/2.0.0.15

When working in a form field (textarea), to mark text to be manipulated, one can 
hold down the <Shift> key and tap a cursor key to mark to left or right 
of the current cursor location.
 
One can also hold down <Shift+Ctrl>, and tap a cursor key to highlight 
to the beginning of the next WORD left or right.  The physical instance of <Ctrl> or <Shift> doesn't matter: either left or right or a mixture of both sides works the same.
 
This works correctly if I use the dedicated cursor keys.  However, it does not work correctly if using the NumPad cursor diamond (the Number Pad numbers): instead, the action appears to be mapped to move focus to a different Tab entirely.
 
This works correctly in the Windows version of FF 2.0.0.15.  AFAICT, it has never worked correctly for any FF 2.x version.

Reproducible: Always

Steps to Reproduce:
1. Open nine or more tabs, with any sites (I use Google).
2. Change the first tab to point to a site with a text entry box.  For example, www.google.com has a one-line Search field: that'll do.
3. Type some text.  Any text that has spaces and chars will do.  For example, "Mary had a little lamb"
4. With the cursor is positioned at the end of the text (rightmost), hold down <Ctrl+Shift>, tap <CurLeft> to confirm that text marking is working correctly using the dedicated cursor keys.  Text will become highlighted with each tap of <CurLeft>.
5. Repeat, using <Ctrl+Shift>, <NumPad4>.
Actual Results:  
Tab focus moves to the fourth tab.

Expected Results:  
Tab focus remains with the first tab, and text marking to the left occurs.

I have reproduced this aberrant behaviour back to FF 2.0.0.0 .  FF 2.x for Windows works as expected.  SeaMonkey 1.x works as expected.
(Reporter)

Updated

10 years ago
Summary: <Ctrl+Shift><NumPad4-6> while focus in textbox does not mark text; moves tab focus. → <Ctrl+Shift><NumPad4-6> while focus in textbox does not mark text; instead, moves tab focus.
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0 Branch

Comment 1

10 years ago
Al, thanks for taking time to file this bug. It's been quite a while since this problem was discussed in the mozilla.dev.ports.os2 newsgroup, so I have forgotten most of the extra details. I tried to read up on it but couldn't make much sense of the discussion any more.

So I used PmW-Fx 2.0.0.15 and could reproduce the problem (with this bug page on the first tab) and then tried Firefox 3.0 and could not reproduce any more. I tried with NumLock on and off.

According to http://support.mozilla.com/en-US/kb/Keyboard+shortcuts the key combo Ctrl+1(to 8) selects tab (1 to 8), the same is listed in the online help of Firefox 2.

In principle, I would have thought that one needs to debug the functions nsWindow::OnKey and WMChar2KeyCode() in widget\src\os2\nsWindow.cpp to see what is going on. But those have not changed in any relevant matter between PmW-Fx 2.0.0.15 and FF 3, so I don't know what's going on.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS/2 is no longer a supported platform.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.