Search: Case where search news crashes

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P3
critical
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: laurel, Assigned: Navin Gupta)

Tracking

({crash})

Trunk
Future
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
Using jun30 m17 commercial build

A crash occurs in the following case doing a search on a migrated newsgroup
which hasn't yet been opened in 6.0.

Steps to reproduce:
1.  Migrate a 4.x file having subscribed newsgroups.
2.  In 6.0 launch to mail, login to mail account.
3.  Search|Search Mail.  Select a newsgroup in the search scope dropdown.
4.  Click Search (you haven't set any criteria yet).

Result: a crash occurs.  

Talkback incident 13415677 for NT 4.0:


 Call Stack:    (Signature = nsMsgSearchNews::ReportHits 374a4a1a) 
     
  nsMsgSearchNews::ReportHits 
                                       
[d:\builds\seamonkey\mozilla\mailnews\base\search\src\nsMsgSearchNews.cpp, line
416]
     
  nsMsgSearchNews::CurrentUrlDone 
                                       
[d:\builds\seamonkey\mozilla\mailnews\base\search\src\nsMsgSearchNews.cpp, line
313]
     
  nsMsgSearchSession::OnStopRunningUrl 
                                       
[d:\builds\seamonkey\mozilla\mailnews\base\search\src\nsMsgSearchSession.cpp,
line 420]
     
  nsUrlListenerManager::BroadcastChange 
                                       
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsUrlListenerManager.cpp, line
84]
     
  nsUrlListenerManager::OnStopRunningUrl
                                       
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsUrlListenerManager.cpp, line
113]
     
  nsMsgMailNewsUrl::SetUrlState 
                                       
[d:\builds\seamonkey\mozilla\mailnews\base\util\nsMsgMailNewsUrl.cpp, line 109]
     
  nsMsgProtocol::OnStopRequest 
                                       
[d:\builds\seamonkey\mozilla\mailnews\base\util\nsMsgProtocol.cpp, line 233]
     
  nsNNTPProtocol::OnStopRequest 
                                       
[d:\builds\seamonkey\mozilla\mailnews\news\src\nsNNTPProtocol.cpp, line 988]
     
  nsOnStopRequestEvent::HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line
302]
     
  nsStreamListenerEvent::HandlePLEvent 
                                       
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line
106]
     
  PL_HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 576]
     
  PL_ProcessPendingEvents 
                                       
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 539]
     
  _md_EventReceiverProc 
                                       
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 1034]
     
  USER32.dll + 0x1820 (0x77e71820)
(Reporter)

Updated

18 years ago
Severity: normal → critical
Keywords: crash
QA Contact: lchiang → laurel

Comment 1

18 years ago
nominating to beta3 since we don't think this is common enough for beta2. adding 
to release notes for beta2
Keywords: nsbeta3, relnote2
Target Milestone: --- → M18

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 2

18 years ago
Adding mail4 triage nomination keyword.
Keywords: mail4

Comment 3

18 years ago
- per mail triage.  A crash is severe, but due to the circumstance of getting 
the crash, we will minus.

Laurel - I don't believe this is possible for IMAP, right?  I recall for IMAP, 
the user gets a login prompt?
Whiteboard: [nsbeta3-]
(Reporter)

Comment 4

18 years ago
If you haven't logged in to the IMAP account, you'd get an alert (bug #44577)
but no login prompt.  If you have logged in, then nothing happens for IMAP (or
POP) accounts -- no crash, no search results, no nothing.

Comment 5

17 years ago
Sorry for the extra mail. Removing mail4 keyword.
Keywords: mail4
It seems unclear to me whether this bug requires either of a "developer" or 
"user" release note for Netscape 6 RTM. If anyone feels it does, can they please 
draft one and then nominate with the relnote-user or relnote-devel strings in 
the Status Whiteboard.

Thanks :-)

Gerv

Comment 7

17 years ago
filters/search UI->gayatrib
Assignee: alecf → gayatrib
Status: ASSIGNED → NEW

Comment 8

17 years ago
A patch has been posted in bug 44591 that would fix this bug.
Marking this dependent on 44591.
Status: NEW → ASSIGNED
Depends on: 44591

Updated

17 years ago
No longer depends on: 44591

Comment 9

17 years ago
Sorry i accidentally updated the wrong bug. I meant bug 44354 and not this bug. 
Ignore the previous comment.

Updated

17 years ago
Target Milestone: M18 → ---

Updated

17 years ago
Target Milestone: --- → Future

Comment 10

17 years ago
reassigning to naving
Assignee: gayatrib → naving
Status: ASSIGNED → NEW
(Reporter)

Comment 11

17 years ago
Seems to be ok current builds (may30). I know there's a more current build
logged by seth about massive assertions when searching a newsgroup which hasn't
been opened yet, but we don't crash.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 12

17 years ago
MAkring verified worksforme
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.