In Print and Preview in minimum one line is cut off from page 1 to 2 [with position:absolute]

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: Delete, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9) Gecko/2008061004 Firefox/3.0

On a certain web site one line is cut off from page 1 to 2 in print or preview function. I tested this bug with Mac OS an Win XP and two different printers.

Reproducible: Always

Steps to Reproduce:
1. Go to web site (see URL)
2. Print or preview the first two pages
3. Compare content from web site with print or preview
Actual Results:  
In minimum one line is missing

Expected Results:  
A propper print.

Comment 1

10 years ago
This is caused by using position:absolute on .content-printable, and more specifically, the offset from top
.content-printable {
	position: absolute;
	width : auto;
	left: 0px;
	right: 0px;
	top: 62px;
	/* ... */
}

Obviously, bug 154892 didn't fix everything.

Confirming, as I don't find any obvious dupes.
Status: UNCONFIRMED → NEW
Component: General → Printing
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → printing
Summary: In Print and Preview in minimum one line is cut off from page 1 to 2 → In Print and Preview in minimum one line is cut off from page 1 to 2 [with position:absolute]
Version: unspecified → Trunk

Comment 2

10 years ago
Created attachment 328185 [details]
test case, minimised from URL
(Reporter)

Comment 3

10 years ago
Created attachment 328186 [details]
exact, bug depends from top offset. simple test case here ...

Comment 4

4 years ago
WFM?  I don't a problem with either testcase on windows, using current nightly build
Flags: needinfo?(phiw2)
Flags: needinfo?(bugzilla)
Whiteboard: [closeme 2015-01-10 WFM]

Comment 5

3 years ago
Testing (print to pdf) with a recentish nightly build on OS X Yosemite, this appears to work now.

There have been lots of changes since this bug was originally filed…
Flags: needinfo?(phiw2)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bugzilla)
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2015-01-10 WFM]
You need to log in before you can comment on or make changes to this bug.