Repeated requests for favicon.ico

RESOLVED DUPLICATE of bug 403408

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 403408
10 years ago
10 years ago

People

(Reporter: Eric, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME 403408 or something like that?)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; Win64; x64; .NET CLR 2.0.50727; SLCC1; Media Center PC 5.0; .NET CLR 3.0.04506)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

When viewing a website that does not have a favicon.ico (i have not tested if this happens with websites that do) firefox makes two requests for the same ico file within seconds of each other.

Thus, one page view on a website results in this log in the servers error_log.

127.0.0.1 - - [04/Jul/2008:08:00:32 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:08:00:35 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"

Additionally, when switching between already open tabs, just viewing a tab results in yet another request for favicon.ico.
This happens no matter how much time has passed between requests.

This wastes resources/bandwidth and leaks information to the website operator and anybody monitoring the connection as to how long the visitor left the tab open.

Firefox should check once for existence of favicon on the first visit to a domain during any session, it should not send multiple requests when it has already learned that the file does not exist.

Reproducible: Always

Steps to Reproduce:
1. Open website in firefox and monitor connection with packet sniffer or logs on the website server.
2. See multiple requests for favicon.ico
3. Open another tab and visit any website or switch to already open tab.
3. Return to the first tab, firefox makes another request for favicon.
Actual Results:  
This is a log from a website server, all these requests resulted from one page view, the additional favicon requests were result of switching between already open tabs.

127.0.0.1 - - [04/Jul/2008:08:00:17 +0000] "GET /index.php HTTP/1.1" 200 1004 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:08:00:21 +0000] "GET /style.css HTTP/1.1" 304 - "http://127.0.0.1/index.php" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:08:00:25 +0000] "GET /images/header.jpg HTTP/1.1" 304 - "http://127.0.0.1/index.php" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:08:00:32 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:08:00:35 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:16:54:01 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:16:54:01 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:17:06:53 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:17:07:36 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:17:07:48 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:19:14:12 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:19:18:33 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:19:18:47 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:19:20:02 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:19:20:16 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:19:20:25 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"


Expected Results:  
127.0.0.1 - - [04/Jul/2008:08:00:17 +0000] "GET /index.php HTTP/1.1" 200 1004 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:08:00:21 +0000] "GET /style.css HTTP/1.1" 304 - "http://127.0.0.1/index.php" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:08:00:25 +0000] "GET /images/header.jpg HTTP/1.1" 304 - "http://127.0.0.1/index.php" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
127.0.0.1 - - [04/Jul/2008:08:00:32 +0000] "GET /favicon.ico HTTP/1.1" 404 209 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0"
Do you have disk/memory caching disabled (possibly via the web developer toolbar)?
(Reporter)

Comment 2

10 years ago
disk caching enabled, memory caching disabled.

Updated

10 years ago
Whiteboard: DUPEME 403408 or something like that?

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 403408
You need to log in before you can comment on or make changes to this bug.