Startup: CID is undefined

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: klaus, Assigned: prazak)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.9) Gecko/2008052906 Firefox/3.0

I get a warning box on startup with text: "TypeError: Component.classes[CID] is undefined" After clicking ok, FF starts up. This happens after a restall. 

Reproducible: Always

Steps to Reproduce:
1. uninstall Microsoft Visual C++ 6.0
2. startup Firefox
3.



I have uninstalled Microsoft Visual C++ 6.0

Comment 1

11 years ago
Not quite clear what MSVC has to do with this.  Please explain more.

Regardless, I suggest giving Firefox safe mode a try:
http://support.mozilla.com/en-US/kb/Safe+Mode
or possibly a new profile:
http://support.mozilla.com/en-US/kb/Managing+Profiles

It sounds like an add-on of some sort is doing this.  If it doesn't have this error in safe mode then that's probably the case.  Disable the add-ons one at a time until you find the cause.  (try plugins after extensions if you need to)  If you find an add-on that does this, then please reply back here with its name and version.
(Reporter)

Comment 2

11 years ago
You are quite right. I should have tried that from the start. It tourned out that it was the AVG Safe Search 8.0 that was the culpit.

Thank you. :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 3

11 years ago
Glad to hear you've solved the problem.  FIXED is for when a bug has been fixed by a change from Mozilla.  This bug is INVALID because it turned out to be an AVG problem.  Please report this issue to them.
Resolution: FIXED → INVALID

Updated

11 years ago
Assignee: nobody → prazak
You need to log in before you can comment on or make changes to this bug.