the IcedTea 1.7 java plugin for 64 bit browser is recognized but does not work

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: netghost, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 2.0.50727; .NET CLR 1.1.4322; .NET CLR 1.0.3705)
Build Identifier: firefox 3.0 

          For SUSE 11.00 X86_64 distribution, the IcedTead java plugin the browser is recognized (using about:plugins),does work well for Konqueror (I have KDE installed) but Firefox 3.0 crashes at each and every applet tried on the SUN applet tests site. 
                              

Reproducible: Always

Steps to Reproduce:
1. try any applet on sun site
2.
3.
Actual Results:  
Java plugin crashes 

Expected Results:  
The gcjxyz.so lib is activated and crashes the error message that is advising to run firefox with -g option in a terminal window. Of course doing that brings no new information. 


It is the 3rd firefox version in which java plugins do not work for 64 bits browser, and frankly I am dissapointed that KDE can do it and firefox can not...
(Reporter)

Updated

10 years ago
Severity: normal → major
This looks like the plugin itself is crashing and that means you have to ask the IcedTead developers about that. That it works in Konquerer doesn't mean that it's Firefox fault.

Please attach a stack trace (no binary mini dump) that shows that the plugin itself is not crashing.

marking incomplete
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Component: Extension Compatibility → General
Resolution: --- → INCOMPLETE
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> This looks like the plugin itself is crashing and that means you have to ask
> the IcedTead developers about that. That it works in Konquerer doesn't mean
> that it's Firefox fault.
> 
> Please attach a stack trace (no binary mini dump) that shows that the plugin
> itself is not crashing.
> 
> marking incomplete
> 

        I find this answer a bit pushy, to say the least. Of course, you might be right, there is a chance, maybe even a big chance, that the bug could be in the plug-in. 
        What is really upsetting me is the fact the attitude. You are so very sure the bug is not in Firefox and it sounds very much like, "i decided that the bug is not with Firefox, unless you prove me I'm wrong".
        In the X86_64 architecture, Firefox has problems with java plugin on (Suse) Linux since over 6 months. Mozilla site indicates that there is finally a solution: the usage of IcedTea plugins! 
        I wanted just to report that this is not a solution for Firefox. is that a firefox problem? how can I tell? How can I test , how can I know?? I do not know how to provide you with the information you bluntly request.

        
          

          
If you crash then attach a stacktrace.
You can do that either with a crash ID from an original Mozilla.org build that sends a crash report, type about:crashes to get the ID or you can generate a stacktrace with your tools from SuSe.

You seem to think that bugzilla is for helping with your problems and you get support here but that is not true, this a technical bug database.
We can look here for bugs in Firefox but we can not fix bugs in other products and if there is a bug in the plugin then please report this to the plugin developer, not us. The plugin crashes always if I read comment #0 and I'm sure that this is the plugin itself.
(Reporter)

Comment 4

10 years ago
 Thanks for you answer and patience..
 I used the word "crash" literally. In fact the plug-in pops-up an error message that says:
" gcjwebplugin error: Failed to run /usr/lib64/jvm/java-1.7.0-icedtea-1.5_b24/jre/lib/amd64/../../bin/pluginappletviewer.  For more detail rerun "firefox -g" in a terminal window."
 Running Firefox from a terminal window with -g option changes nothing to the behavior.
 Now indeed, if I interpret the double ".." as go one directory higher, under "jre" directory there is no "bin" directory at all and according to the message it should be one containing "pluginappletviewer"
It looks like there is something wrong configured with your plugin.
I know from the sun plugin that you have to symlink it because it can not find the JVM if you just copy it.
If it can not find the JVM (like in your case) it just calls exit() and the browser dies with the plugin because the plugin runs in the same process space.

There must be a config file for the plugin and there must be a "pluginappletviewer" somewhere...
I would not interpret the .. as home, i would interpret it as middle of a much longer path but I'm only a wine32 user and could be wrong.
Isn't there a Linux Forum or a Forum from the Plugin developers where you could get help ?

(Reporter)

Comment 6

10 years ago
As you advised me, I posted this problem on OpenSuse forum and I got the following answer that works perfectly for me on Suse 11.0 X86_64
"...I don't know if this will fix your problem, but I had problems with applets working with IcedTea 1.7. I removed all components for IcedTea in Yast, and then installed the older version OpenJDK 1.6. Applets now work in firefox for me. I am using the 64 bit version of everything, specifically, the following packages:
java-1_6_0-openjdk
java-1_6_0-openjdk-plugin
..."
So it works :-))))
(Reporter)

Updated

10 years ago
Resolution: INCOMPLETE → FIXED
nothing changed in teh source = not fixed
great that it works now for you
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.