moz-icon://*?size=### where ### is a number > 127 gives error message 'The image "moz-icon://*?size=###" cannot be displayed, because it contains errors.'

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: kim, Unassigned)

Tracking

(Blocks: 1 bug)

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061017 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061017 Firefox/3.0

moz-icon://*?size=### where ### is a number > 127 results in the error message 'The image "moz-icon://*?size=###" cannot be displayed, because it contains errors.'

Reproducible: Always

Steps to Reproduce:
1. Go to moz-icon://.js?size=128 or any other valid moz-icon.
Actual Results:  
Error message:
The image "moz-icon://.js?size=128" cannot be displayed, because it contains errors.

Expected Results:  
Image should have been rendered.

Problem is still there in safe mode with a clean profile.
Also happens when using Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1a1pre) Gecko/2008070504 Minefield/3.1a1pre
Blocks: 599904
(Reporter)

Comment 1

8 years ago
WFM now on Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100927 Firefox/4.0b7pre Gentoo.
WFM Mozilla/5.0 (X11; Linux i686; rv:2.0b7pre) Gecko/20100928 Firefox/4.0b7pre
Up to moz-icon://.xml?size=255, it fails to load anything beyond size 255
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> Up to moz-icon://.xml?size=255, it fails to load anything beyond size 255

Looks like it might be due to this:
http://hg.mozilla.org/mozilla-central/file/d0d3ac2ce08c/modules/libpr0n/decoders/icon/gtk/nsIconChannel.cpp#l102

So, not an error per se.
Mhm, i’d seen your post on another icon bug report, could this bug be closed?

I wonder if a bug/patch should be filed to cap the size at 255 instead, because at the moment icons just wont load rather than being the largest they could be (255).
(Reporter)

Comment 5

8 years ago
I would think so, but I don't know and dare not make any changes.

256 would be better as that would avoid scaling when such an icon exists in the theme. Anything but silently failing would be good in my book.

Updated

8 years ago
Version: unspecified → 3.0 Branch
WFM with latest Nightly, build ID: 20130825030201.

Please reopen this bug if you can still reproduce the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.