Can't start Firefox 3.0: looped fatal error

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: jjj, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.15) Gecko/20080625 Ubuntu/7.10 (gutsy) Firefox/2.0.0.15
Build Identifier: http://www.mozilla.com/en-US/products/download.html?product=firefox-3.0&os=linux&lang=en-US

I'm running Gutsy.
I installed Firefox 3 (final release) by downloading it from mozilla and it ran fine for a couple of days, but now whenever I try to open it crashes with this error:
Error: in guard: symbol required but got: Error: fatal: looped fatal error

I think it may have had to do with the "Add Bookmark Here" extension, which I installed the last time before it started crashing.

I deleted the directory containing firefox (i.e. ~/firefox), then unzipped a fresh copy from mozilla. I tried deleting the ~/.mozilla folder. I also opened the old version of Firefox 2 (which runs ok) and uninstalled "Add Bookmark Here". None of these things have worked though, I still can't run Firefox 3.


I deleted .mozilla then created a new profile using the command firefox -p.
So now Firefox 2 had no extensions installed. I also now have Firefox 3 beta 4 (out of the repository) and that works fine too.
But the full release of Firefox 3 from the mozilla site does not work - it gives me the fatal loop error.

I have tried following the instructions on ubuntuzilla but these result in the same error message.

Reproducible: Always

Steps to Reproduce:
1. Download Firefox for Linux
2. Extract archive
3. Try running firefox
Actual Results:  
Crashes immediately with:
Error: in guard: symbol required but got: Error: fatal: looped fatal error

Expected Results:  
Start
you might want to read http://bugs.gentoo.org/show_bug.cgi?id=213080
(Reporter)

Comment 2

9 years ago
Thank you - the problem was with UIM. I uninstalled it and it worked.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
nothing changed in the mozilla source = not fixed, marking wfm

btw: what is UIM ?
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 4

9 years ago
Yes, perhaps something should be fixed in Mozilla so this doesn't surprise someone else.
UIM-anthy is one of the tools you can use for inputting Japanese in Ubuntu. Apparently this issue has been fixed in the new version of UIM but it hasn't made it into the repositories yet... Still it would be nice if Firefox could defend itself against problems like this a bit better.
You need to log in before you can comment on or make changes to this bug.