The CSS doesn't load correctly.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Robert Sale, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.15) Gecko/20080623 Firefox/2.0.0.15
Build Identifier: Firefox 3

Whenever I explore certain sites such as Myspace.com or Forums.facepunchstudios.com the CSS doesn't load correctly. Like some of the text starts bunching up with other text and usually there will be borders around words that wont load, so the words just bunch up in the corner.

The only way that I've found to fix it is to install Firefox 2.0.0.15 but the latest Firefox is the one with the problem.

Reproducible: Always

Steps to Reproduce:
1. Go to one of the mentioned websites in the details
2. Wait for page to load
3. Watch as the page morphs into unreadable garbage
Actual Results:  
Most, if not all of the text becomes unreadable garbage. Usually it bunches up in the corner and then the text starts overlapping. Also the borders and other page elements disappear. This problem makes Firefox 3 almost impossible to use. I'm guessing it's the CSS render.

Expected Results:  
The text loads the way it should, in it's own designated area, not overlapping other text, and the borders load properly, giving the text a place to stay on the webpage.

The only additional information I can give is my system info:

Operating System: Windows XP SP3
CPU: Intel Core 2 Duo 6700
GPU: GeForce 8600 GTS
ISP: Comcast High Speed (I know they suck)

And that all the other Web Browsers I've used don't have this problem.

Opera 9
Apple Safari
IE 7
Netscape

Comment 1

10 years ago
> the CSS doesn't load correctly. Like some of the
> text starts bunching up with other text and usually there will be borders
> around words that wont load, so the words just bunch up in the corner.

I do not see the text or words bunching up when usign Firefox 3 rv:1.9 build 2008052906 under XP Pro SP3. 
Which corner is it anyway? 
Can you please attach a screenshot using the "Add an attachment" link?

After a superficial examination of the webpage, note that 

- the webpage uses conditional comment targeting IE 6 and IE 7 with extensive CSS code, from line 61 to line 130

- 
http://jigsaw.w3.org/css-validator/validator?uri=http://www.myspace.com/
reports many CSS parsing errors involving CSS hacks, with some of them obviously targeting IE 7.

- the markup code involves 136 validation errors
http://validator.w3.org/check?uri=http://www.myspace.com/

- there is a large <style> block within the body element from line 190 to line 217 with 15 rules and 34 declarations: that is all invalid

- there are many scripts functions which modify dynamically classes or css rules or inline style. It would take considerable amount of time to figure out what actually all this dynamic code does and for which browser and for which browser version

- there is another <style> block within the body element from line 470 to 477

- there are 27 (twenty-seven) <script>s in that webpage with a majority of them located in the body element. It would take a considerable amount of time to figure out what all these <script>s do exactly and for which browser and which browser versions

- there is a 3rd <style> block in the body element

- etc.
Robert, could you perhaps upload a screenshot of what you are seeing?
Because the websites you mentioned look perfectly fine here.

Comment 3

10 years ago
No response for over 7 weeks. 

Resolving as WORKSFORME

Robert, you may reopen the bug if you can provide the requested info and/or a reduced testcase
http://developer.mozilla.org/en/Reducing_testcases
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.