If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Download folder preference is sometimes ignored

VERIFIED DUPLICATE of bug 311292

Status

()

Toolkit
Downloads API
--
major
VERIFIED DUPLICATE of bug 311292
9 years ago
9 years ago

People

(Reporter: Bill Walker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

I have the preference set in both Firefox and Safari to download folders to my ~/Downloads folder (i.e., the Mac OS 10.5.3 "official" downloads folder).  Lately Firefox has been intermittently ignoring this preference and placing downloaded files on the Desktop instead.  I can find no pattern to which files end up where.

Reproducible: Sometimes

Steps to Reproduce:
1.In Firefox preferences, use the "choose" button and select /Users/<self>/Downloads as your download folder and check the box telling Firefox to use it.
2.Download files from various sites (e.g., software packages).
3.Look for the files in the Downloads folder, and discover that they're missing, sometimes.
4. Find the missing files on the Desktop.
Actual Results:  
Sometimes the downloaded files end on the Desktop instead of in the Downloads folder.

Expected Results:  
The files should always be downloaded to the folder selected in the preferences.
Are they are placed on the desktop if you launch the file with a helper application and it works if you just download them ?
(Reporter)

Comment 2

9 years ago
No, it's without a helper app in both cases....  I think.  Hmm, it could be that the ones going on the desktop are the ones being opened by Stuffit Expander.  But it's still the case that the original downloaded file ends up on the desktop instead of the designated download folder.
Which makes it a dup of bug 311292.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 311292

Updated

9 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.