On a Russian email-service site some source code of the page is seen in the created email, after the text has been pasted from MS Word and the mail has been sent or saved

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Alexei, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

I could spot this bug only with a page, which uses Windows-1251 charset. The site is www.rambler.ru.

After sending or saving an email with Russian text, pasted from MS Word, and then opening its saved version, I get this at the beginning of the letter:

<!-- /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-parent:""; margin:0cm; margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:12.0pt; font-family:"Times New Roman"; mso-fareast-font-family:"Times New Roman";} @page Section1 {size:612.0pt 792.0pt; margin:2.0cm 42.5pt 2.0cm 3.0cm; mso-header-margin:36.0pt; mso-footer-margin:36.0pt; mso-paper-source:0;} div.Section1 {page:Section1;} --> 

After looking at the page's source, I noticed that symbols '<' and '>' are replaced with their codes '&lt;' and '&gt;' there, so that the above fragment of code ceasess to be an HTML comment.

P.S. The same very page works fine in Opera and Seamonkey.

Reproducible: Always

Steps to Reproduce:
1. Create an email with a registered account on www.rambler.ru.
2. Type some Russian in MS Word and copy the text into a new email.
3. Send or save the email and open its saved version. The Addressee also gets a fragment of the source code.
Actual Results:  
Described in Details above.

Expected Results:  
It shouldn't have inserted code fragments into the email.
This is a mass search for bugs that are in the Firefox General component, are
UNCO, and have not been changed for 800 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile,
http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you
still see the bug, please update this bug. If the issue is gone, please set the
resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 2

8 years ago
I have tested it as you said, the bug is gone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.