windows visible too early

VERIFIED FIXED in M8

Status

()

P4
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: danm.moz, Assigned: danm.moz)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

20 years ago
New nsWebShellWindows should be created invisible, and made visible only after
they've been initialized.  Specifically, after their size has been calculated
and set -- currently, the border flashes at the default size before they are
resized.

Comment 1

20 years ago
I'd suggest keeping them invisible even longer -- until most (all?) of the chrome
has been laid out. This would avoid the ugly toolbar grooving and shaking that
happens now. Of course, if you are fetching chrome bits remotely, you might
want to detect this and show something earlier.

Updated

20 years ago
Priority: P3 → P4
Target Milestone: M7

Comment 2

20 years ago
assigning to danm as p4 for m7
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

20 years ago
Target Milestone: M7 → M8
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

20 years ago
This is a hairy, many, many sided problem.  But we've been augering in on it and I think
we're there.

Updated

20 years ago
Depends on: 8468
Whiteboard: will wait for bug 4438 before verification

Comment 4

20 years ago
the problem is much improved on windows NT 4.0 and MacOS 8.51,
but linux still has resizing issues.

i'm leaving this RESOLVED FIXED until bug 8468 is fixed.

Updated

20 years ago
Status: RESOLVED → VERIFIED
Whiteboard: will wait for bug 4438 before verification

Comment 5

20 years ago
verified on

     1999-07-12-08 RedHat Linux 5.2 kernel 2.2.9
     1999-07-12-08 WinNT 4.0 sp4
     1999-07-12-08 MacOS 8.51
You need to log in before you can comment on or make changes to this bug.