If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Incorrect behavior of overflow:scroll style on tbody

RESOLVED DUPLICATE of bug 135236

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 135236
9 years ago
4 years ago

People

(Reporter: Mumax, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0

A tbody with a height and an overlap:scroll style show the following behavior:

- cell backgrounds are not scrolled
- cell backgrounds are not clipped

For detailed behavior, please run attached HTML file.

This is an update of Bug 322609 for Firefox 3.0

Reproducible: Always

Steps to Reproduce:
Please run attached html file.
Actual Results:  
- cell backgrounds are not scrolled
- cell backgrounds are not clipped


Expected Results:  
Content of tbody is properly scrolled and clipped.
(Reporter)

Comment 1

9 years ago
Created attachment 328256 [details]
HTML file that reproduces the bug with explanations.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → style-system
Version: 3.0 Branch → 1.9.0 Branch
Duplicate of this bug: 322609

Comment 3

9 years ago
The 'overflowing background' on <tr> is already tracked in bug 423823.
The second issue (borders are not scrolled) is bug 135236.
Whiteboard: dupeme
Dupping to the open bug on the remaining issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Summary: Incorrect behavior of overlap:scroll style on tbody → Incorrect behavior of overflow:scroll style on tbody
Duplicate of bug: 135236
Oh, and please don't file separate bugs per version unless the behavior is actually different...

Updated

4 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.