If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[@ js_NewObjectWithGivenProto] Random crashes while using Meebo

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: sdaugherty, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: qawanted, URL)

(Reporter)

Description

9 years ago
From a conversation at http://getsatisfaction.com/mozilla/topics/firefox_crashed_again the user is experiencing frequent random crashes using Meebo in Firefox 3 on Windows XP SP3 with no extensions.

http://crash-stats.mozilla.com/report/index/f4761421-4b1b-11dd-8580-001a4bd43ed6 is one such crash.

Comment 1

9 years ago
There's a JS_CloneFunctionObject on the stack here, so I thought Igor might find this interesting.
(Reporter)

Comment 2

9 years ago
I'm still trying to reproduce... I doubt this will be a windows-only bug from looking at the breakpad report, but it may be - due to it being an intermittent crash this one could be "fun" to pin down. 

I'm hoping I'll get another stack trace or two in the next day or so...
There are some similar stack traces in crash-stats though:
http://crash-stats.mozilla.com/report/list?range_unit=weeks&query_search=signature&query_type=contains&signature=js_NewObjectWithGivenProto&query=js_NewObjectWithGivenProto&range_value=1

Whiteboard: qawanted
(Reporter)

Comment 3

9 years ago
Two more crash reports from the user:

http://crash-stats.mozilla.com/report/index/86b9875c-466b-11dd-9d6a-001cc4e2bf68
http://crash-stats.mozilla.com/report/index/dd96e7c2-43d0-11dd-935b-001cc4e2bf68

I think the second is more likely to be directly related.

Comment 4

9 years ago
the nspr frame is suspicious. luser?

Signature	js_NewObjectWithGivenProto
UUID	f4761421-4b1b-11dd-8580-001a4bd43ed6
Time	2008-07-05 22:25:16-07:00
Uptime	1199
Product	Firefox
Version	3.0
Build ID	2008052906
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 6 model 14 stepping 8
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x4
Comments	
Crashing Thread
Frame 	Module 	Signature 	Source
0 	js3250.dll 	js_NewObjectWithGivenProto 	mozilla/js/src/jsobj.c:2560
1 	js3250.dll 	js_NewObject 	mozilla/js/src/jsobj.c:2465
2 	js3250.dll 	JS_CloneFunctionObject 	mozilla/js/src/jsapi.c:4256
3 	xul.dll 	xpc_CloneJSFunction 	mozilla/js/src/xpconnect/src/xpcwrappednativeinfo.cpp:56
4 	xul.dll 	XPCNativeMember::NewFunctionObject 	mozilla/js/src/xpconnect/src/xpcwrappednativeinfo.cpp:124
5 	xul.dll 	XPCWrapper::GetOrSetNativeProperty 	mozilla/js/src/xpconnect/src/XPCWrapper.cpp:686
6 	xul.dll 	XPC_NW_GetOrSetProperty 	mozilla/js/src/xpconnect/src/XPCNativeWrapper.cpp:528
7 	xul.dll 	XPC_NW_GetProperty 	mozilla/js/src/xpconnect/src/XPCNativeWrapper.cpp:534
8 	js3250.dll 	js_NativeGet 	mozilla/js/src/jsobj.c:3561
9 	js3250.dll 	js_Interpret 	mozilla/js/src/jsinterp.c:4161
10 	js3250.dll 	js_Invoke 	mozilla/js/src/jsinterp.c:1313
11 	js3250.dll 	fun_call 	mozilla/js/src/jsfun.c:1589
12 	js3250.dll 	js_Interpret 	mozilla/js/src/jsinterp.c:4835
13 	js3250.dll 	js_Invoke 	mozilla/js/src/jsinterp.c:1313
14 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp:1523
15 	xul.dll 	nsXPCWrappedJS::CallMethod 	mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp:559
16 	xul.dll 	PrepareAndDispatch 	mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
17 	xul.dll 	SharedStub 	mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
18 	nspr4.dll 	PR_CallOnceWithArg 	
19 	xul.dll 	nsTimerImpl::Fire 	mozilla/xpcom/threads/nsTimerImpl.cpp:408
Summary: @js_NewObjectWithGivenProto Random crashes while using Meebo → [@ js_NewObjectWithGivenProto] Random crashes while using Meebo
Yeah, those NSPR symbols don't seem to match reality, do they? They also don't seem terribly relevant to the stack though. I'll take a look at it at some point.

Comment 6

9 years ago
I am also seeing random crashes in FF 3.0.1 on Kubuntu.  It starts loading all the javascript files and then just crashes before even reaching the first screen.

I was trying to track it down but now it's not doing it anymore.  More if I learn anything.

Comment 7

9 years ago
http://crash-stats.mozilla.com/report/index/e9d9fec3-cb34-4992-9c99-b35d02081219
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 470223
Sorry, I meant that comment 7 is about bug 470223, not the 3.0.1 or older crashes reported in earlier comments. Don't just match top frame to find the bug, look for more recent bugs with same signature.

/be
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 10

6 years ago
I'm not finding evidence of any more of these crashes. Going to close as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.