valgrind errors for editor/composer/src/crashtests/428844-1.html (due to building without --with-valgrind)

RESOLVED INVALID

Status

()

Core
Editor
RESOLVED INVALID
10 years ago
5 years ago

People

(Reporter: Robert Sayre, Assigned: peterv)

Tracking

({intermittent-failure, valgrind})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
I can reliably reproduce this error. Running the composer crashtests under valgrind also reliably reproduce crashtest hanging on exit, while running other crashtest files does not reproduce the hang.
(Reporter)

Comment 1

10 years ago
Created attachment 328259 [details]
valgrind log

To reproduce:

1) ./run-mozilla.sh /bin/bash
2) valgrind ./firefox-bin --reftest=/home/sayrer/dev/mozilla-central/editor/composer/src/crashtests/crashtests.list &> valgrind-composer.log
(Reporter)

Updated

10 years ago
OS: Mac OS X → Linux
(Reporter)

Comment 2

10 years ago
The errors of interest are 

==6038== Conditional jump or move depends on uninitialised value(s)
==6038==    at 0x5D1F583: nsIHTMLDocument::IsEditingOn() (nsIHTMLDocument.h:159)

and the assertions nearby.

Comment 3

10 years ago
Peter can you take a look since hg-blame pins those lines on you?  We've been having crashtest hangs repeatedly on linux so would be great to figure this out..
Assignee: nobody → peterv
(Assignee)

Comment 4

10 years ago
That's a bit odd, IsEditingOn returns

GetEditingState() == eDesignMode || GetEditingState() == eContentEditable

and GetEditingState returns nsHTMLDocument's mEditingState, which should be set to 0 by the nsIDocument's zeroing new() operator.
(Assignee)

Comment 5

10 years ago
Created attachment 328320 [details] [diff] [review]
Fix valgrind warning

This probably fixes the valgrind warnings (Robert, can you confirm that?), but it shouldn't make any difference for the hang unless our zeroing operator new isn't working. The assertions are a problem and we should fix them at some point, but they shouldn't cause hangs either.

Updated

10 years ago
Blocks: 438871

Comment 6

10 years ago
I can reproduce the valgrind error using a stock jemalloc-enabled build.
In a build with "ac_add_options --with-valgrind" I don't get the error,
so I think this is a bogus error from valgrind, see bug 424040 comment 10.

Comment 7

10 years ago
(In reply to comment #5)
> This probably fixes the valgrind warnings 

It doesn't help.  I think --with-valgrind is required for reliable valgrind
results on jemalloc builds.

Updated

10 years ago
Keywords: valgrind
(Assignee)

Comment 8

10 years ago
(In reply to comment #7)
> It doesn't help.  I think --with-valgrind is required for reliable valgrind
> results on jemalloc builds.

Robert, did you set that option? If not could you rerun with it set?

I'm going to be away till Wednesday next week, so if this is urgent you should look for a better owner.
(Reporter)

Comment 9

10 years ago
yep, that's it. sorry.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Summary: valgrind errors for editor/composer/src/crashtests/428844-1.html → valgrind errors for editor/composer/src/crashtests/428844-1.html (due to building without --with-valgrind)

Comment 10

9 years ago
I'm confused.  Is peterv's patch in comment 5 bogus?

This crashtest is causing crashes for me, btw.
(Assignee)

Comment 11

9 years ago
Jesse: it shouldn't make a difference. AFAIK Robert was building without the required --with-valgrind. I think it'd be better to file a new bug on the crash.
Whiteboard: [orange]
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.