Pasting URL or text into URL bar crashes Camino

RESOLVED DUPLICATE of bug 439215

Status

Camino Graveyard
Location Bar & Autocomplete
--
critical
RESOLVED DUPLICATE of bug 439215
10 years ago
10 years ago

People

(Reporter: tom, Unassigned)

Tracking

({crash})

1.8 Branch
PowerPC
Mac OS X
crash

Details

(Whiteboard: [CLOSEME - 8/3])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.14) Gecko/20080512 Camino/1.6.1 (like Firefox/2.0.0.14)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.14) Gecko/20080512 Camino/1.6.1 (like Firefox/2.0.0.14)

When pasting a URL or text for Smart Bookmarks searching into the URL field of the toolbar can crash the browser. This has happened repeatedly. It might be the case that Camino crashes if the text includes a carriage return (CR) at the end of the line. This can easily happen when copying and pasting from a text doc. 

Reproducible: Sometimes

Steps to Reproduce:
1.Copy & paste text with CR into URL bar
2.hit return
3.browser hangs, unresponsive, beach ball. 
Actual Results:  
browser hangs, unresponsive, beach ball. 

Expected Results:  
access url, access smart bookmark or display an error.
(Reporter)

Updated

10 years ago
Version: unspecified → 1.8 Branch

Comment 1

10 years ago
This sounds an awful lot like bug 439215, which was INVALID (a bug in 1Password).
Can you please *attach* the Mac OS X crash log in plain-text format as described on http://caminobrowser.org/documentation/bugzilla/#crash
Keywords: crash

Comment 3

10 years ago
Without a response to comment 2, I'm going to go ahead and assume this is a dupe of bug 439215.

Tom, if you have evidence that it is NOT a duplicate of that bug, please feel free to provide said evidence and re-open this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 439215
You need to log in before you can comment on or make changes to this bug.