If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Reset QA Contact to default" fails with strict_isolation turned on if there is no default QA contact

RESOLVED FIXED in Bugzilla 3.2

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Frédéric Buclin, Assigned: Frédéric Buclin)

Tracking

({regression})

3.1.4
Bugzilla 3.2
regression
Bug Flags:
approval +
approval3.2 +
blocking3.2 +

Details

Attachments

(1 attachment)

755 bytes, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Assignee)

Description

9 years ago
Created attachment 328279 [details] [diff] [review]
patch, v1

If a bug is restricted to a bug, "Reset QA Contact to default" always fails if there is no QA contact by default, because _check_qa_contact() has:

        $invocant->_check_strict_isolation_for_user($qa_contact)
            if ref $invocant;

But $qa_contact is the user object by default (the one with ID = 0) and so _check_strict_isolation_for_user() will complain that this powerless user is not allowed to edit bugs in this product.

We should omit this check if there is no QA contact, i.e. if $qa_contact->id = 0. I didn't check if 3.0.4 is affected, but I'm pretty sure this is a regression in 3.2 due to the refactoring of process_bug.cgi.
Flags: blocking3.2+
Attachment #328279 - Flags: review?(mkanat)

Comment 1

9 years ago
Comment on attachment 328279 [details] [diff] [review]
patch, v1

Looks good to me.
Attachment #328279 - Flags: review?(mkanat) → review+

Updated

9 years ago
Flags: approval3.2+
Flags: approval+
(Assignee)

Comment 2

9 years ago
tip:

Checking in Bugzilla/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.247; previous revision: 1.246
done

3.1.4:

Checking in Bugzilla/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.241.2.4; previous revision: 1.241.2.3
done
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.