Illigal characters in object names

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
P3
normal
RESOLVED INVALID
18 years ago
7 years ago

People

(Reporter: Vladimir Ermakov, Unassigned)

Tracking

({dom0})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
No error occurs when the name attribute is set to an illigal value 
from javascript.  I attach a testcase which demonstrates this.
(Reporter)

Comment 1

18 years ago
Created attachment 10889 [details]
a testcase assigning an illigal name to an input
According to the HTML spec at:

 
http://www.w3.org/TR/1998/REC-html40-19980424/interact/forms.html#adef-name-INPUT

"name" attributes are of type CDATA which means that just about any character,
including all the ones in the testcase, "#$)*@(BLAH1032", are valid characters.

Marking as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 3

18 years ago
Johnny

DTD spec for CDATA for "id" and "name" says that token must begin with letter 
[A-Za-z]
here is link
http://www.w3.org/TR/html4/types.html#type-cdata
It says "ID and NAME tokens must begin with a letter ([A-Za-z]) and may be 
followed by any number of letters, digits ([0-9]), hyphens ("-"), underscores 
("_"), colons (":"), and periods ("."). "

It could contain any chars but beginning char should be letter.
4.x does not accept non letters but N6 does. Something is wrong.
Reopening bug.


Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

18 years ago
confirming new.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

18 years ago
Created attachment 11014 [details]
a better illustration of the bug
This bug has been marked "future" because the original netscape engineer
working on this is over-burdened. If you feel this is an error, that you or
another known resource will be working on this bug,or if it blocks your work
in some way -- please attach your concern to the bug for reconsideration.
Status: NEW → ASSIGNED
OS: Windows 98 → All
Hardware: PC → All
Target Milestone: --- → Future
(Reporter)

Updated

17 years ago
QA Contact: desale → vladimire
Keywords: dom0
Mass-reassigning bugs to dom_bugs@netscape.com
Assignee: jst → dom_bugs
Status: ASSIGNED → NEW
Imo this should be wontfix -- we don't perform parsing-type validity checks on
any of our DOM manipulations, nor should we...
Isn't this a dup of a bug that just got a patch?

Comment 10

14 years ago
bug 16603?
Assignee: general → nobody
QA Contact: vladimire → general
Invalid per <http://www.whatwg.org/html/#dom-fe-name>.
Severity: major → normal
Status: NEW → RESOLVED
Last Resolved: 18 years ago7 years ago
Resolution: --- → INVALID
Target Milestone: Future → ---
You need to log in before you can comment on or make changes to this bug.